Mattermost, Inc.

What AWS settings should be used to self-host Mattermost?

Hello there,
I am wondering where to find the AWS settings from amazon.

I am running it on a self-hosted server in OVH and I have a amazon AWS account but I do not know where to find the settings that are needed for mattermost.

Also since I am not running it on EC2 do I need the Route53 settings ?

Hi robotheram,

Mattermost should run fine without the AWS settings filled in in the config file. You only need the S3 related settings if you want to be able to upload files/images in mattermost. For that just set up an S3 bucket and AWS should give you the right values to put into the corresponding settings in config.json. In the next major release we plan on adding the ability to just use local storage for files/images instead of using S3.

The Route53 stuff is only required if you want Mattermost to automatically map domains for you when you create new teams. If you’re running in dev mode this won’t happen and if they settings are not set it also won’t happen. So you can ignore the Route53 settings if you don’t want to use it.

Thanks,

Joram

Hello I added the settings but get a strange error when I try to upload a image

Unable to upload file. Put
/mattermostdata/teams/9o3ean8sobd9iy15ikz9x71jor/channels/97gqqe8gc7r55ddbc9zi55u7ic/users/zzobx6q6xpdzpjbkuxpqcoc51w/wdudjs6bzpdjjrm3crz9bjgi3h/image-63.jpg:
unsupported protocol scheme ""mdonniugrt8odjjy4srt4urnrc500

The settings in config_docker and config.json are

I am using the latest version of the project but also had this problem on helium

"AWSSettings": {
        "S3AccessKeyId": "AccessID",
        "S3SecretAccessKey": "***Secret****",
        "S3Bucket": "mattermostdata",
        "S3Region": "US Standard",        
        "Route53AccessKeyId": "",
        "Route53SecretAccessKey": "",
        "Route53ZoneId": "",
        "Route53Region": ""
    },

I know that the S3 settings are correct as they are the same for the S3 account for multcloud.com and I can add files to that account

Everything looks good for your S3 settings except the region needs to be formatted using the region identifiers here http://docs.aws.amazon.com/general/latest/gr/rande.html#s3_region

So for “US Standard” you would use “us-east-1”. Try that out and let me know if it works for you.

Thanks @jwilander changing the region to the correct format worked. I look forward to all the updates

Glad to hear it :smile:

Hi, I also have a related question:

I’m running a version of mattermost on a custom cloud infrastructure that also supports S3. But clearly it is not part of amazon.
My config looks like this:

AWSSettings": {
        "S3AccessKeyId": "xxx",
        "S3SecretAccessKey": "xxx",
        "S3Bucket": "CHAT",
        "S3Region": "https://os.zhdk.cloud.switch.ch"
}

Is it possible to work with an S3 object storage outside of Amazon?

Hello there It is possible for s3 to work outside of Amazon my setup is on a custom dedicated server.
Look in the S3 bucket properties and change the region to the one specified. If it says like mine US Standard change it to us-east-1 and it should work fine