Mattermost, Inc.

Setting up Bitnami-Mattermost

For completeness, I’m using “bitnami-mattermost-5.12.1-0-linux-debian-9-x86_64”

I have the virtual appliance running on a local ESXi 5.5 server.

I did a:

  • sudo ifconfig

ens32: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.10.34. netmask 255.255.255.0 broadcast 192.168.10.255

I’ve assigned the appliance a static IP address:

  • cd /etc/systemd/network
  • sudo cp 99-dhcp.network 25-wired.network
  • sudo edit 25-wired.network

[Match]
Name=ens32

[Network]
Address=192.168.10.34/24
Gateway=192.168.10.1
DNS=192.168.10.1

On the router, I’ve setup DDNS with NO-IP such that the site URL is always pointing to my WAN IP
I’ve also forwarded port 80 and port 443 to internal IP address 192.168.10.34

I’ve filled-out the info for the first ‘user’ and the first ‘team’ in Mattermost

I’ve run nslookup www.redacted.com
And I see:

So, I have reason to believe this part is working

From Mattermost [System Console:Web Server:Site URL] I’ve tried repeatedly to change h#ps://192.168.10.34 to:

  • h#ps://www.redacted.com
  • h#p://www.redacted.com
  • h#ps://redacted.com
  • h#ps://redacted.hopto.org
    However, [:Site URL] always returns to the value of h#ps://192.168.10.34 after each server reboot.
    I’m purposely using ‘#’ in place of ‘tt’, because of the limitation on links that I’m permitted in this message.

When I try to access Mattermost from outside my LAN, I see it make its way through the NO-IP redirection and my router, but the browser shows my local IP address 192.168.10.34 in the URL bar, which is of course unreachable from outside LAN and the page loading process halts.

I’ve also previously broken my install a couple times trying to setup the [:listening port], [:forward port 80 to 433] and getting [:use let’s encrypt] to work. I kept ending up with the dreaded 502 Gateway Error and not being able to undo my changes, I was forced to reinstall the VM and begin setup all over again. Which is where I am now, pretty much a ‘virgin’ install, except for the static IP changes and trying to change [System Console:Web Server:Site URL]

I’ve spent a couple evenings now reading about how to fix one issue and then another, but I’m not making any progress at this point, so I’m hoping someone might be able to assist me in getting my Mattermost site running well enough that it can be accessed from outside my local network and with a certificate.

Thank you.

Hi @ljmarent, Did you save your changes and is the configuration file writable by Mattermost?

The crew over at Bitnami were able to help me with this.
It was their bnconfig file, it was rewriting my config.json and nginx.conf files on boot.
After I set them correctly, I renamed the bnconfig file to bnconfig.disabled and it stopped causing me all the grief.

I’m now able to access the server both from the inside and the outside. The only odd thing I notice now, is that uf I log in from the internal network and request a team link, it gives me a link with the internal IP address instead of the www.redacted.com . This is resolved by logging in from outside the network, but it feels a bit buggy…