Mattermost, Inc.

No team creation method has been enabled. Please contact an administrator for access

No team creation method has been enabled. Please contact an administrator for access.

I only add

# in /etc/gitlab/gitlab.rb
mattermost_external_url ‘http://chat.simcu.com

but it can’t work well
the page shows:
No team creation method has been enabled. Please contact an administrator for access.

what should i do?

Hi xrain0610,

You should be able to enable team creation by finding and uncommenting the following line in your gitlab.rb and then running sudo gitlab-ctl reconfigure.

# mattermost['team_enable_team_creation'] = true

can’t work,
I use the docker version, 8.8.3
and config GITLAB_OMNIBUS_CONFIG

external_url 'http://code.simcu.com
registry_external_url 'https://registry.simcu.com
mattermost_external_url 'http://chat.simcu.com
gitlab_rails[‘gitlab_email_from’] = 'code@service.simcu.com’
gitlab_rails[‘gitlab_email_display_name’] = 'SIMCU CODE’
gitlab_rails[‘gitlab_email_reply_to’] = 'code@service.simcu.com’
gitlab_rails[‘smtp_enable’] = true
gitlab_rails[‘smtp_address’] = "xxxx"
gitlab_rails[‘smtp_port’] = 25
gitlab_rails[‘smtp_user_name’] = "xxxxx"
gitlab_rails[‘smtp_password’] = "xxxx"
gitlab_rails[‘smtp_authentication’] = "login"
gitlab_rails[‘smtp_enable_starttls_auto’] = false
gitlab_rails[‘smtp_ssl’] = false
gitlab_rails[‘smtp_tls’] = false
gitlab_rails[‘smtp_openssl_verify_mode’] = 'none’
gitlab_rails[‘gitlab_default_projects_features_container_registry’] = true
gitlab_rails[‘registry_path’] = "/var/opt/gitlab/registry/"
mattermost[‘team_enable_team_creation’] = true

but it can’t work well , you can visit chat.simcu.com

Hi @xrain0610, for the full flexibility of Mattermost you can follow the migration guide to move Mattermost outside of GitLab. Alternatively, you could install the production Mattermost instance and then connect that with GitLab SSO on separate instances?

Thanks,
But I only want to use inside mattermost ,
and some days ago , It can’t work well, then I turn the sso ,
but I can’t turn off it ,
I use the offical docker images,
the sso page always shows, I can’t disabled it ,
what should i do?