Mattermost, Inc.

Mobile emojis are not displayed properly on Chrome or Windows client

Summary

Emojis picked from the Android or iOS system keyboards are not displayed properly on Chrome or Windows client.

Steps to reproduce

Mattermost server 5.17.1 using mariaDB 10.4 on Debian 10, with utf8mb4 encoding.
Post a message from the Android Mattermost mobile app, containing an emoji picked from the Android system keyboard (not the Mattermost emoji picker). Display the message on Chrome or Windows client and notice that the emoji is not displayed properly.
Custom emojis enabled.

Expected behavior

The emoji should be either converted to a “Mattermost-compatible” emoji or displayed like Firefox is doing.
Note that emojis picked from Mattermost are displayed just fine and emojis “manually typed” (for ex: :p) are properly displayed everywhere.

Observed behavior

Windows client / Chrome above
Firefox below
emoji1

This earlier thread might help: Using the mobile emoji keyboard renders "?" on other platforms.

What Windows version are you on?

Hi!

Thanks, I’ve already read that thread when looking for support. Unfortunately the solution to the problem in this thread was to set the DB connection charset to utf8mb4. My Mattermost server has always been set-up with utf8mb4 and it’s been only 1 or 2 major version upgrades since the problem appeared.

I’m using Windows 10 build 1909 currently. Problem was the same with 1903.

Hi!

It looks like version 5.18.0 fixed the problem :slight_smile:

2 Likes