Mattermost Peer-to-Peer Forum

Disabling user email notifications by default


#1

It looks like you have to set “Settings > Notifications > Email > Enable email notifications” to true in order to turn off “Preview Mode”. Is there some way to change the default user account setting “Notifications > Email notifications” to be “Never”, so when our users sign up they don’t get a bunch of emails unless they really want to?


#2

Hi @ryantm,

Thanks for your question,

I’ll check with a product manager but, at present, I don’t think there is a way to turn off email notifications in the system console without having the ‘preview mode’ banner displayed.


#3

@ryantm Not currently, although you can consider enabling email batching in System Console > Notifications > Email. This will bundle emails together from a set time period.

Have you found people complaining about being inundated with too many email notifications?


#4

Hi, Jason.

We haven’t started using Mattermost extensively yet, and I just turned on the email notifications, so I’m not sure. However, at my company, we do not use email for internal communication at all (we use IRC almost exclusively), so getting any emails at all will be kind of annoying. Also, some people at the company don’t really even have email, but would still be using the chat.

Ryan


#5

Hi, did you solve this problem? Is it possible to turn off email notifications?


#6

Hi, @skole9299

If you are referring to turning off email notifications per profile, you should be able to do it through Account Settings >> Notifications >> Email >> set the Send email notifications to Never.

Unless you are referring to a different method to switch off the email notifications, are you alluding about the ability to completely disable email notification during user creation as per the question by @ryantm?


#7

First, thanks for the response!

I am talking about the ability to completely disable email notification during user creation. Is there a way to do that?

Also, even though I set email notifications ( Account Settings > Notifications > Email) on never - but I still receive email notifications.

P.S. We created an app based on mattermost - https://itunes.apple.com/ua/app/86d/id1441434894?mt=8


#8

Hi, @skole9299

You are most welcome! As of now, I believe that there is no feature available that allow admins to set that flag during user creation so far. Do you have any specific use case that you can share to us in regards to the need of having it? Maybe something similar to @ryantm where emails are not really important?

Also, even though I set email notifications ( Account Settings > Notifications > Email) on never - but I still receive email notifications.

Can you confirm what kind of email notifications that you are still getting? Are you referring to mentions and direct messages or something else? Also, can you confirm that you click on Save after you make the changes as well? Thanks.


#9

Yes, I am referring to DM and mentions. Having push notifications is enough, we do not need an email for every DM or mention. Just imagine that for every WhatsApp message you get an email, no one needs that.

Essentially, I am wondering if there any way we can disable email notifications for all users?

Regarding you question - “confirm that you click on Save after you make the changes as well”?

  • On our app we do not have an option to click on save. We have a check mark next to an option you choose. Even though I choose to never receive an email, I am still getting them.
    Do you think that the problem is on our end or that is just how mattermost works at the moment(I really believe that there is no way mattermost would allow behavior where after every DM or mention you get an email)?

Thanks for the help!


#10

Hi @skole9299,

Do you have email notifications turned off both on webapp and mobile app?


#11

Hello, @skole9299

Thank you for providing the details. In regards to the statement here:

Having push notifications is enough, we do not need an email for every DM or mention. Just imagine that for every WhatsApp message you get an email, no one needs that.

Definitely. Hence, that is the reason why you are allowed to tailor the email notification according to your preference on the client preference and the mails will only be sent when you are offline / away from Mattermost for more than 5 minutes. Else, it will be too spammy.

On our app we do not have an option to click on save

This is an interesting point. Can you please confirm on the environment that you are running on?

  • OS version
  • Mattermost version
  • Client version (desktop & mobile)

The reason why I want to go through these points is because I checked through the Mac & Linux client (as well as web client) and verified that there should be a button available to Save the preference you set.

On the mobile side, this is how it looks like on the iOS client:

Perhaps you are referring to the mobile client here? May I know if you are able to share the screen shot of what you are seeing on your end?

Additionally, I would like to see if we can poke the database for more information on the notification preference. Can you run the following SQL command and share the output here?
SELECT NotifyProps FROM Users WHERE email = "<email_address>";

For comparison, I will share the example that I have when I have the toggle set to each option:

Immediately
mysql> SELECT NotifyProps FROM Users WHERE email = "<email_address>";
+----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+
| NotifyProps |
+----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+
| {"channel":"true","comments":"never","desktop":"mention","desktop_sound":"true","email":"true","first_name":"false","mention_keys":"adanial,@adanial","push":"mention","push_status":"away"} |
+----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+
1 row in set (0.00 sec)

Never
mysql> SELECT NotifyProps FROM Users WHERE email = "<email_address>";
+--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+
| NotifyProps |
+--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+
| {"auto_responder_active":"false","auto_responder_message":"Hello, I am out of office and unable to respond to messages.","channel":"true","comments":"never","desktop":"mention","desktop_sound":"true","email":"false","first_name":"false","mention_keys":"adanial","push":"mention","push_status":"away"} |
+--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+
1 row in set (0.00 sec)

That will help us to confirm if the preference was indeed saved into the system properly. Thanks!


#12

Hi @adanial @amy.blais !! As soon as I get feedback from my team I will get back to you!
Thanks again, I appreciate it!