Mattermost, Inc.

Can't configure SSL with Let's Encrypt on Mattermost Docker

Summary

I can’t configure SSL with Let’s Encrypt on Mattermost Docker

Steps to reproduce

  • Install Mattermost Production Docker by following the instructions here.
  • Prior to building images, in docker-compose.yml comment out the 2 lines for team edition and 2 lines for MATTERMOST_ENABLE_SSL.
  • Access to the server within a browser : Mattermost run successfully without SSL
  • Go to System Console => Configuration and change :
    • site url : https://…
    • listen address : :443
    • Connection Security : TLS
    • Use Let’s Encrypt : true
    • Forward port 80 to 443: true
  • Restart server (docker-compose restart)
  • Try to access Mattermost server from browser : the URL is redirected from http to https, but the server can’t be reached (“Connection failed” in Firefox).

Expected behavior

Well, I want to enable SSL with the Mattermost production Docker.
Am I missing something ? Step 4 of the production Docker documentation redirect here but it doesn’t mention the Let’s Encrypt setting available in the System Console.

Thank you !
Greetings,
Michaël Polla

Hi, has anyone a suggestion ?

Hi @michaelpolla,

Thanks for your feedback,

Here are a couple of places you might find help for your issue:

Let me know if any of the above help :slight_smile:

Did you solve this in the end? I’m having the same issue.

See also: