Where to find Mattermost after installing GitLab omnibus?


#1

hi

I installed the Girlab Mattermost bundle…I see gitlab :slight_smile: but where is the mattermost install located?

adam


#2

I read this:
http://doc.gitlab.com/omnibus/gitlab-mattermost/README.html

and enabled mattermost in the config. However when I run reconfigure the subdomain for mattermost is active but just points at the gitlab install…Im using Ubuntu 1404


#3

Hi @booksprint, please see the steps in the GitLab Mattermost install guide to setup Mattermost from the GitLab omnibus.

Here’s more details on GitLab Mattermost from GitLab.com


#4

thanks…I read this but one of the tings it doesnt mention is that you should also enable mattermost in the gitlab.rb config…:slight_smile: that worked…

thanks for your help

adam


#5

Sorry for asking a very stupid question: I have modified gitlab.rb to include

external_url 'http://casgitlab.casalelug.ch
mattermost[‘enable’] = true
mattermost_external_url ‘http://192.168.0.213

but I still do not understand how to access mattermost. Which url should I call?


#6

The URL is not a URL on your MAIN host it’s a whole different virtual host with a different DNS name.

If you read the docs twice, you might find that the first time you missed some essentials, and the second time you grabbed on to them. That’s what happened to me…

  1. If your machine has a DNS entry for casgitlab.casalelug.ch, go add a second DNS entry for chat.casalelug.ch, or whatever you want your mattermost to have.
  2. Follow instructions to set it up. Including creating API key.
  3. Because mattermost is a multitenant application you will find that visiting http://chat.casalelug.ch" will request that you now create a Team (until there’s a team, there’s no other feature in Mattermost that you can access).
  4. After you have a team you will see the main mattermost ui.

#7

Has anyone used that Gitlab/Mattermost document and has gotten the system to work without any additional changes that have not been mentioned there? I think I’m incompatible with their documentation :frowning:

I’m probably missing something quite obvious. I have gitlab omnibus running inside of a virtual machine on a Windows Server in a network that I don’t have admin access to.
I wan’t to activate Mattermost.
Following the documentation i put down “http://mattermost.gitlab-srv” as the mattermost_external_url (gitlab itself is reachable at “http://gitlab-srv”).
Now, if I take the documentation at face-value, that should be it (spoiler alert: it isn’t).

I probably need to add the subdomain somewhere but I’m not quite sure how to do that (can I do that on the virtual machine im running or do I have to add that in our networks DNS server?), and where to point it to get this running.


#8

It’s probably NOT that you’re incompatible.

In my case, the difficulty of getting this working comes from me not initially understanding all that is going on:

  1. I am using mattermost as part of a gitlab “omnibus” installation, and understanding what the “omnibus” thing is doing as it updates and manages things (with chef, I believe) leads to some confusion at times.

  2. The mattermost documentation refers to things that don’t exist like some /opt/mattermost/bin/platform executable. The name of the executable (platform) is is a stupid historical accident and like all stupid historical accidents is not worthy of mention anywhere in any documentation, and so it’s a stumbling block for new users who are not even expecting to learn mattermost (they are just gitlab users). In the omnibus repackage of the mattermost binaries, they did a sensible rename to actually name the main mattermost binary to mattermost.

  3. Database schema upgrades have of late proved an extreme source of pain since the mattermost omnibus chef recipes are trying to automate a bunch of (I believe) postgres SQL schema change updates during updates. These are failing routinely on me, between 7.x and 8.x updates. Even fresh installs of Gitlab Omnibus followed by enabling Mattermost in gitlab.rb were not working on a fresh clean VM out of the box for me as recently as June 2016. I may need to retry that clean VM test now that gitlab 8.9.5 CE is released.

  4. Troubleshooting tools provided with the gitlab+mattermost are sorely lacking. Also any notes on how to manually start up mattermost are sorely lacking. When I determine a useful shell hack, I have a pattern of making a shell script for that purpose. I have built up quite a little library of mattermost and gitlab shell scripts that I use to diagnose things when things go pear shaped.

here’s one I recommend to everyone: I have this as /root/gitlab-mattermost
When mattermost is not runnable (because Go panic, a Panic is Go’s uber-shitty and opinionated replacement for exceptions), it helps to run it from your root shell, while impersonating (with sudo -u mattermost) the correct user account so you can see it panic, or so you can run some command like -upgrade_db_30.

#!/bin/sh
cd /opt/gitlab/embedded/service/mattermost
sudo -u mattermost /opt/gitlab/embedded/bin/mattermost -config=/var/opt/gitlab/mattermost/config_alt.json $@

Usage examples:

/root/gitlab-mattermost -version

/root/gitlab-mattermost -help

There, I invoked mattermost and if I got a version output then mattermost’s Go codebase is not in a pissy mood, and feels like running without panicking.
It may be pissy about localization and just dump core when you try to run it, or anything else. If it is, you have to figure out how to fix the gitlab-mattermost binary or its supporting files. When it’s in a mood like that, obvious your gitlab and mattermost integration is NOT working.

Note also that mattermost is pissy about what the current directory is, and that’s why my shell script above forces a current working directory before running the command line command. Instead of saying “hmm, maybe you’re in the wrong directory” when you run the mattermost binary, it’s going to panic with some irrelevant message about english localization files not being found. Nice.

W


How to enable Mattermost service?
[SOLVED] Gitlab Omnibus 9.3.x installer does not upgrade Mattermost
#9

I am reviving this dead thread because the title is exactly what I do not understand. I installed gitlab omnibus and I enabled MM in the gitlab.rb. I can go to mattermost.myserver.com and I see a normal MM install. But I thought it was supposed to integrate with GitHub somehow?


#10

Hi @SSD! Thank you for reaching out.

Can you help give more details on what you are seeing?
Does this doc help https://docs.gitlab.com/omnibus/gitlab-mattermost/?


#11

Amy that doc has never helped anyone. It would be equally useful if it was written in Klingon.

No I described everything I see. When I go to mattermost..com I see a standard MM install. But in GitLab I do not see anything that suggests to me that MM is integrated. So my question is the title of this thread: “Where to find Mattermost after installing GitLab omnibus?” It is really a simple question. I am asking where I should find MM after I install Gitlab omnibus and enable MM.

There is one exception I just learned: when I create a new project I have a box I can check to create a MM thread. If I check it then I get errors but that is another Issue.


#12

@SSD The integration between the two is that:

  1. Logging into Mattermost using GitLab is enabled and configured by default. You can see this under the Applications setting in the admin area in GitLab. This is where it would show up if you installed them separately and connected them manually, but again, it’s configured by default
  2. Under a project’s Settings > Integrations, you can add a slash command in Mattermost to interact with that project

#13

you can add a slash command in Mattermost to interact with that project

Can you tell me what this means? I guess “slash command” is something specific to Mattermost and I guess I will learn about it when I use it. But what do you mean by “interact with that project”?

What I am wondering is: after I install MM (which I am convinced is impossible because I’ve been trying for days and SSL is still not functioning but that is another issue), where in GitLab will I see this “integration”? If I have to go to some other URL then what is the value of having them connected? I am not being rude I really want to know what the benefit of this integration is because right now I can’t see it and since there are no screenshots or explanations or anything I don’t know if I should continue to spend time making this work (or exactly how I will know when they do work.)


#14

Correct, the slash command is in Mattermost. It lets you do stuff with issues and deploy code with GitLab CI currently. Here’s a screenshot of it from within Mattermost

As for seeing Mattermost from within GitLab, I don’t think there’s anything for that currently. As far as I know, it’s only accessible from the URL that you’ve configured in gitlab.rb


#15

Okay. I guess I don’t see what value GL-MM adds then if it is not integrated with GL itself. I can guarantee that zero of the users of this system will learn a slash command. They won’t even type a URL into their browsers.