Mattermost Peer-to-Peer Forum

Where do I find a list of mattermost plugins?


#1

There’s a list of integrations, but no list of plugins I can find. Surely there must be a list of available plugins somewhere? Google isn’t being helpful…


#2

Hi @Routhinator,

Great question, here are some lists of plugins we have - some created by us and many others created by community members:


#3

you guys should create a plugin market where users can browser and download/install plugins.

Have the dev details and so on.


#4

@RbDev Here’s a snapshot of what we’re working with regards to a plugins marketplace :slight_smile:


#5

:+1: … … (why post minim 20 chars)


#6

This is a very useful information for me. Thanks!


#7

So I’ve tried some of these plugins - and I see a universal problem that I can’t seem to solve (and can’t find any references in any forum).

On the dice roller one I get this error message in the log:
{“level”:“error”,“ts”:1552603548.0702062,“caller”:“log/log.go:289”,“msg”:“error fetching remote image: Get /icon.png#0x0: Get /icon.png: address forbidden, you may need to set AllowedUntrustedInternalConnections to allow an integration access to your internal network”,“source”:“stdlog”}

While I do find the icon.png in the plugin directory - I have no idea how to tell my nginx reverse proxy how to find that file despite numerous attempts.

Suggestions? (had a similar issue with the meme generator on the test page - I’ve turned on the AllowedUntrustedInternalConnections and it didn’t do anything)


#8

Hi @wmq,

A response from a community member:

The file in question should be in mattermost/plugins/com.github.moussetc.mattermost.plugin.diceroller . (And, they believe that no nginx configuration change should be required.)


#9

Here’s what nginx says about the query for the icon.png (which is located in the proper place in the plugin directory):

me/61.0.3163.100 Electron/2.0.12 Safari/537.36" “-” “[removed IP]:8065” “200”
10.232.253.64 - - [15/Mar/2019:17:36:59 -0500] “GET /api/v4/image?url=%2Fplugins%2Fcom.github.moussetc.mattermost.plugin.diceroller%2Ficon.png HTTP/1.1” -> 500 <- NOT FOUND REPORT FROM MATTERMOST SERVER 260 “-” “Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Mattermost/4.2.0 Chrome/61.0.3163.100 Electron/2.0.12 Safari/537.36” “-” “[Removed IP]:8065” “500”

Mattermost log shows:
{“level”:“error”,“ts”:1552689411.2189186,“caller”:“log/log.go:289”,“msg”:“error fetching remote image: Get https://[removed IP]/icon.png#0x0: Get https://[removed IP]/icon.png: address forbidden, you may need to set AllowedUntrustedInternalConnections to allow an integration access to your internal network”,“source”:“stdlog”}

Mattermost config section:
“EnableInsecureOutgoingConnections”: false,
“AllowedUntrustedInternalConnections”: “1”,
“EnableMultifactorAuthentication”: false,

(I had a “true” in there, the server upon load apparently converted it to “1”).

I get the same results with the meme maker - the mattermost server refuses to deliver the images.

Suggestions?

If I can get this to work adding plugins like this will be an easy matter, and creating them will be just as easy.


#10

Hi @wmq,

What Mattermost version are you on? If it includes the image proxy: is the image proxy turned on? If so, could you please try to turn it off? (Also, re HTTP status codes: 500 is not 404.)


#11

Ok - turning off the “local” image proxy made the image appear properly!

A different error showed up in the mattermost log, but the picture loaded:
{“level”:“warn”,“ts”:1552911463.354878,“caller”:“app/post_metadata.go:204”,“msg”:“Failed to get dimensions of an image in a post”,“post_id”:“6oseaisxwfgdxbs1ecx4x9b3ra”,“image_url”:"/plugins/com.github.moussetc.mattermost.plugin.diceroller/icon.png",“err”:“Get https://[redacted ip]/plugins/com.github.moussetc.mattermost.plugin.diceroller/icon.png: address forbidden, you may need to set AllowedUntrustedInternalConnections to allow an integration access to your internal network”}


#12

Hi @wmq,

Also wanted to mention that we made some fixes around image proxy in 5.8.1 and 5.9 releases - see more details in important upgrade notes: https://docs.mattermost.com/administration/important-upgrade-notes.html.