Mattermost, Inc.

Websocket: origin not allowed

Server Windows 2012 R2
Installed with this tut: https://docs.mattermost.com/install/prod-windows-2012.html
Mattermost Version 3.7.3
Reversproxy is configured
NO SSL is used.

Summary

[2017/03/29 10:19:56 CEST] [EROR] websocket connect err: websocket: origin not allowed
[2017/03/29 10:19:56 CEST] [EROR] /api/v3/users/websocket:connect code=500 rid=zwgkfaegdbga8ms6c6g51wxjgo uid= ip=217.110.83.5 Failed to upgrade websocket connection [details: ]

After update the Mattermost Server from 3.6 to the last version the error are filling the systemlog.
The server runs but, sometimes the messages didn´t show up, only after a refresh.
i googling the error but i didnt find the right solution. I hope that someone can help me.
Thank You

Hey @torsten, thanks for the report,

We have a fix included in Mattermost v3.8 (released April 16th), which adds WebSocket CORS support and should resolve the issue you’re describing. The first release candidate is available on April 4th if you want to try it out.

We also recommend configuring reverse proxy with NGINX, not IIS – if you do set it up with IIS, ensure you’re using IIS 8.0 or later and have enabled WebSockets

I am visiting mattermost with multiple URLs. Since 3.8.0, SiteURL is required. Which should I put? Should I put it as in AllowCorsFrom “http://abc.com https://cde.com

@coroninhttp://abc.com https://cde.com” should work . Make sure to include a space in between the two urls

@coronin we just investigated and found out that AllowCorsFrom only supports a single domain name

We have a bug ticket to fix it here: https://mattermost.atlassian.net/browse/PLT-6393

Sorry about that, let us know if you’re hitting any issues with this bug…