Webrtc audio is ok video not works


#1
  1. mattermost/mattermost-preview docker image
  2. linagora/janus-gateway docker image
  3. we can hear sound, but the video doesn’t work. I find a lot of ‘Getting a lot of NACKs (slow downlink) for video’ warns in janus log. How can i solve this problem? Any suggestion is welcome.

#2

Hi @wangzy,

Could you review this web page and send us the relevant logs, config files, etc. so we can diagnose this issue?

Additional details that might be helpful:

  1. What distribution and database is your Mattermost instance installed on?
  2. Which browser/desktop app (and version) are the two users using? How about operating system?
  3. Does the issue reproduce with more than one person?
  4. Does the issue reproduce each time, if you try to call the same person 2-3 times? (sometimes we’ve had issues in the past where first try doesn’t connect)

Can you also help take a look at the tips in these threads:

  1. How to start WebRTC?
  2. Video/audio calls

#3
  1. mattermost is installed by docker. docker run --name mattermost-preview -d --publish 8065:8065 mattermost/mattermost-preview. The version is 5.3.0. janus gateway. I use image built by this source https://github.com/linagora/docker-janus-gateway. turnserver. I use docker image built by this source https://github.com/bprodoehl/docker-turnserver. I didn’t configure any ssl related things, we only use http and ws. and the outgoing insecure connection is enabled.
  2. we both use firefox browser, the version is 61.0.2 and 62.0. the operation system is macOS 10.13.6
  3. yes
  4. we tried many times, but it won’t work. we can hear sound from each other but no video.

#4

@wangzy Are you seeing errors in Mattermost or Janus logs, or browser Console?