Matttermost, Inc.

Webapp | Zoom plugin | bundle js 404

Hi !

I have trooble with zoom plugin. The mattermost page shows the following error:

However the js bundle zoom exists in the folder.

I have long time trying to solve it, but without successfull.

Thanks people !

Hi @sebaripari,

What are your Zoom settings set to in the System Console? Do you see errors in Mattermost logs?

1 Like

Mattermost Settings:

Mattermost log:

Blockquote
{“level”:“debug”,“ts”:1558974611.169278,“caller”:“jobs/schedulers.go:167”,“msg”:“Next run time for scheduler PluginsScheduler: 2019-05-27 13:31:11.169238926 -0300 -03 m=+1249.742972113”}
{“level”:“debug”,“ts”:1558974611.9867337,“caller”:“web/handlers.go:58”,“msg”:“GET - /api/v4/config/client”}
{“level”:“debug”,“ts”:1558974611.9902968,“caller”:“web/handlers.go:58”,“msg”:“GET - /api/v4/license/client”}
{“level”:“debug”,“ts”:1558974612.0504265,“caller”:“web/handlers.go:58”,“msg”:“GET - /api/v4/users/me”}
{“level”:“debug”,“ts”:1558974612.055888,“caller”:“web/handlers.go:58”,“msg”:“GET - /api/v4/users/me/teams”}
{“level”:“debug”,“ts”:1558974612.0567975,“caller”:“web/handlers.go:58”,“msg”:“GET - /api/v4/users/me/preferences”}
{“level”:“debug”,“ts”:1558974612.0626028,“caller”:“web/handlers.go:58”,“msg”:“GET - /api/v4/users/me/teams/members”}
{“level”:“debug”,“ts”:1558974612.075349,“caller”:“web/handlers.go:58”,“msg”:“GET - /api/v4/users/me/teams/unread”}
{“level”:“debug”,“ts”:1558974612.1308253,“caller”:“web/handlers.go:58”,“msg”:“GET - /api/v4/plugins/webapp”}
{“level”:“debug”,“ts”:1558974623.2471676,“caller”:“web/handlers.go:58”,“msg”:“POST - /api/v4/users/status/ids”}
{“level”:“debug”,“ts”:1558974623.3480875,“caller”:“scheduler/worker.go:49”,“msg”:“Worker received a new candidate job.”,“worker”:“Plugins”}
{“level”:“info”,“ts”:1558974623.351702,“caller”:“scheduler/worker.go:78”,“msg”:“Worker: Job is complete”,“worker”:“Plugins”,“job_id”:“f18n3bgorfgp3kqnjuet8uc6mr”}
{“level”:“debug”,“ts”:1558974630.330156,“caller”:“web/handlers.go:58”,“msg”:“POST - /api/v4/users/status/ids”}
{“level”:“debug”,“ts”:1558974630.3530715,“caller”:“app/email_batching.go:110”,“msg”:“Email batching job ran. 0 user(s) still have notifications pending.”}
{“level”:“debug”,“ts”:1558974633.343644,“caller”:“web/handlers.go:58”,“msg”:“POST - /api/v4/users/status/ids”}
{“level”:“debug”,“ts”:1558974633.3449125,“caller”:“mlog/log.go:160”,“msg”:“CSRF Header check failed for request - Please upgrade your web application or custom app to set a CSRF Header”}
{“level”:“debug”,“ts”:1558974633.5742044,“caller”:“web/handlers.go:58”,“msg”:“POST - /api/v4/users/status/ids”}
{“level”:“debug”,“ts”:1558974633.5743482,“caller”:“mlog/log.go:160”,“msg”:“CSRF Header check failed for request - Please upgrade your web application or custom app to set a CSRF Header”}

I could fix the problem by hiding the header in my nginx configuration:

proxy_hide_header X-Content-Type-Options;