Mattermost, Inc.

Webapp Customization cause server to be blank

I have setup the Mattermost-Server on Ubuntu 18.04. The server worked fine, as I accessed through browser “localhost:8065” and created a team.

I have tried to change the logo in the about-modal. So I

  1. forked Mattermost-Webapp.
  2. Created the jsx file, copied it to “components/widgets/icons”.
  3. Imported it in the about-modal jsx and called it at the Logo section.
  4. Packaged it into tar.gz. Copied the tar file to “/opt/mattermost”.
  5. Removed the client folder completely, extracted the tar file and renamed it client.
  6. Restarted the service.

Now when I visit "localhost:8065: there is nothing on the screen.

Here is my Log
{“level”:“info”,“ts”:1573460073.0431979,“caller”:“utils/i18n.go:83”,“msg”:“Loaded system translations”,“for locale”:“en”,“from locale”:"/opt/mattermos
t/i18n/en.json"}
{“level”:“info”,“ts”:1573460073.0433273,“caller”:“app/server_app_adapters.go:59”,“msg”:“Server is initializing…”}
{“level”:“info”,“ts”:1573460073.0447233,“caller”:“sqlstore/supplier.go:222”,“msg”:“Pinging SQL”,“database”:“master”}
{“level”:“error”,“ts”:1573460073.0711205,“caller”:“app/server_app_adapters.go:126”,“msg”:“SiteURL must be set. Some features will operate incorrectly
if the SiteURL is not set. See documentation for details: http://about.mattermost.com/default-site-url”}
{“level”:“info”,“ts”:1573460073.0717375,“caller”:“app/license.go:41”,“msg”:“License key from https://mattermost.com required to unlock enterprise feat
ures.”}
{“level”:“info”,“ts”:1573460073.0732005,“caller”:“mlog/log.go:166”,“msg”:“Starting up plugins”}
{“level”:“info”,“ts”:1573460073.0732284,“caller”:“app/plugin.go:199”,“msg”:“Syncing plugins from the file store”}
{“level”:“info”,“ts”:1573460073.1024575,“caller”:“app/plugin.go:234”,“msg”:“Found no files in plugins file store”}
{“level”:“info”,“ts”:1573460077.630965,“caller”:“mlog/sugar.go:19”,“msg”:“Ensuring Surveybot exists”,“plugin_id”:“com.mattermost.nps”}
{“level”:“info”,“ts”:1573460078.5157452,“caller”:“app/server.go:216”,“msg”:“Current version is 5.16.0 (5.16.3/Wed Nov 6 14:03:31 UTC 2019/533c7bb3e58
47db423387abfcf983e3f947818eb/eb940617df855e3af9c005f9052c7cc3d8e17c30)”}
{“level”:“info”,“ts”:1573460078.5157797,“caller”:“app/server.go:217”,“msg”:“Enterprise Enabled: true”}
{“level”:“info”,“ts”:1573460078.515794,“caller”:“app/server.go:219”,“msg”:“Current working directory is /opt/mattermost”}
{“level”:“info”,“ts”:1573460078.5158024,“caller”:“app/server.go:220”,“msg”:“Loaded config”,“source”:“file:///opt/mattermost/config/config.json”}
{“level”:“info”,“ts”:1573460078.5227952,“caller”:“sqlstore/post_store.go:1356”,“msg”:“Post.Message has size restrictions”,“max_characters”:16383,“max_
bytes”:65535}
{“level”:“info”,“ts”:1573460078.5777292,“caller”:“jobs/workers.go:68”,“msg”:“Starting workers”}
{“level”:“info”,“ts”:1573460078.577798,“caller”:“app/server.go:423”,“msg”:“Starting Server…”}
{“level”:“info”,“ts”:1573460078.5779607,“caller”:“app/server.go:489”,“msg”:“Server is listening on [::]:8065”}
{“level”:“info”,“ts”:1573460078.5781372,“caller”:“jobs/schedulers.go:72”,“msg”:“Starting schedulers.”}
{“level”:“info”,“ts”:1573460078.5839942,“caller”:“app/web_hub.go:75”,“msg”:“Starting 16 websocket hubs”}
{“level”:“error”,“ts”:1573460078.5850012,“caller”:“web/static.go:26”,“msg”:“Failed to update assets subpath from config”,“error”:“failed to find ‘Cont
ent-Security-Policy’ meta tag to rewrite”}
{“level”:“info”,“ts”:1573460078.5864284,“caller”:“commands/server.go:105”,“msg”:“Sending systemd READY notification.”}

Did I do the customization wrong? please guide me.