We're Hiring!

Mattermost, Inc.

"Value changed successfully" but not changed

Summary

Can’t enable plugin uploads

Steps to reproduce

  • Using mattermost omnibus
  • Try to change PluginSettings.EnableUploads: sudo -u mattermost mmctl --local config set PluginSettings.EnableUploads true
  • Check if it changed: sudo -u mattermost mmctl --local config get PluginSettings.EnableUploads
  • Be confused

Expected behavior

I expect sudo -u mattermost mmctl --local config get PluginSettings.EnableUploads to return true

Observed behavior

I observed sudo -u mattermost mmctl --local config get PluginSettings.EnableUploads returned false

ubuntu@ip-172-26-3-183:~$ sudo -u mattermost mmctl --local config set PluginSettings.EnableUploads true
Value changed successfully
ubuntu@ip-172-26-3-183:~$ sudo -u mattermost mmctl --local config get PluginSettings.EnableUploads
false

Can you confirm that your Mattermost files are owned by the correct system user(s), and have read/write permissions?

i don’t think that’s relevant as i thought the config is in the db

ubuntu@ip-172-26-3-183:~$ sudo -u mattermost find /opt/mattermost/ -not -user mattermost
ubuntu@ip-172-26-3-183:~$ sudo -u mattermost find /opt/mattermost/ -not -perm -u+rw
ubuntu@ip-172-26-3-183:~$ sudo -u postgres find /var/lib/postgresql/ -not -user postgres 
ubuntu@ip-172-26-3-183:~$ sudo -u postgres find /var/lib/postgresql/ -not -perm -u+rw

all commands return nothing so i assume that all files are owned by the correct user(s), and have read/write permissions.

And do you have the proper permissions given to your reverse proxy server, so that it is allowed in turn to pass files to the server through the Mattermost Daemon? There aren’t any security policies or file upload restrictions/WAF’s blocking or intercepting your files?

i’m not sure i know what you’re asking. i don’t have an option to upload files because it’s disabled. i can’t seem to enable it.

there is no proxy in front of the mattermost server, beyond what omnibus may have setup.

Hello, @jayenashar

EnableUploads is configured through /etc/mattermost/mmomni.yml. In this case, you have to set enable_plugin_uploads to true and run mmomni reconfigure to apply the changes.

You can check a list of the configuration properties that are set through the mmomni.yml config file here. Hope that helps.

1 Like

thanks. i didn’t encounter either of those when i was searching through the docs. i only found /opt/mattermost/config/config.json and the db.