Upgraded to 4.5 but log still says 4.1


#1

For feature requests, please see: http://www.mattermost.org/feature-requests/.

For troubleshooting questions, please post in the following format:

Summary

attempted to upgrade from 4.1 to 4.5 but log still states running 4.1

Steps to reproduce

follow download instructions

Expected behavior

the log file should no longer reference 4.1

Observed behavior

here is the log…
[2018/01/05 12:01:52 EST] [INFO] Loaded system translations for ‘en’ from ‘/opt/mattermost-4.5.0/i18n/en.json’
[2018/01/05 12:01:52 EST] [INFO] Current version is 4.1.0 (4.1.0/Tue Aug 15 22:11:43 UTC 2017/0033e3e37b12cb5d951d21492500d66a6abc472b/bfbfc8b3cda63993999769bf317d88a0a57c9e97)
[2018/01/05 12:01:52 EST] [INFO] Enterprise Enabled: true
[2018/01/05 12:01:52 EST] [INFO] Current working directory is /opt/mattermost-4.5.0
[2018/01/05 12:01:52 EST] [INFO] Loaded config file from onfig=/opt/mattermost-4.5.0/config/config.json


#2

Hi @dtkloc,

What steps did you follow when upgrading, was it these ones? It looks like your binary is still from 4.1 so my guess is something in the upgrade process went wrong.

Some other useful information that would help troubleshooting would be, how are you running Mattermost? Is it configured as a service, if so can you share the service configuration file? For example for Ubuntu 14.04 it would look like:

start on runlevel [2345]
stop on runlevel [016]
respawn
limit nofile 50000 50000
chdir /opt/mattermost
setuid mattermost
exec bin/platform