We're Hiring!

Mattermost Discussion Forums

Unable to upgrade past v5.33.5

I manage a private Mattermost instance for our team, and due to other tasks taking priority the updating of Mattermost had been sidelined until recently.

I was able to upgrade to 5.33.5, but upon attempting to upgrade to 5.36.2 I’m unable to restart the Mattermost service post-upgrade. journalctl -xe doesn’t appear to show anything of relevance to bring light to the issue (in upgrading to 5.32.1 that did reveal the need to upgrade to PostgreSQL 10.x).

I didn’t see any notable important upgrade notes for the v5.36.x releases, so I’m not sure why the service fails to start post-upgrade. So I’m a bit confused as to what could be the issue at fault here.