Mattermost, Inc.

Unable to reach my server with TLS/Let's Encrypt option enabled

Hey everyone,

I’m here because I can’t reach my server after following process https://docs.mattermost.com/install/config-tls-mattermost.html :
Listen Address setting to :443 .
Connection Security setting to TLS .
Forward port 80 to 443 setting to true .
sudo setcap cap_net_bind_service=+ep /opt/mattermost/bin/mattermost done
Use Let’s Encrypt setting to true .
Restart the Mattermost server for these changes to take effect.

My config.json :
“SiteURL”: “mattermost.mydomainname:443”,
“WebsocketURL”: “”,
“LicenseFileLocation”: “”,
“ListenAddress”: “:443”,
“ConnectionSecurity”: “TLS”,
“TLSCertFile”: “”,
“TLSKeyFile”: “”,
“TLSMinVer”: “1.2”,
“TLSStrictTransport”: false,
“TLSStrictTransportMaxAge”: 63072000,
“TLSOverwriteCiphers”: [],
“UseLetsEncrypt”: true,
“LetsEncryptCertificateCacheFile”: “./config/letsencrypt.cache”,
“Forward80To443”: true,

It’s ok when i’m restarting my mattermost service, but on a web browser, nothing works.

In fact, it’s the same problem as the following topic : [SOLVED] Unable to connect to Matermost server when secure connection is Enabled
But in my situation my “Forward80To443” is set to “true”.

Did i miss something ?

Many thanks in advance. :slight_smile:

Hi @Hindrik-H,

What error messages are you seeing? Are you using Nginx?

try changing the siteurl to {url}:80

1 Like

Nop, I didn’t use apache or nginx.

Thank you for your help but It doesn’t change anything…
Maybe i’ll try with nginx as a proxy