Mattermost Peer-to-Peer Forum

Unable to ping database during installation - Solved

#1

I’m doing a new installation on a RHEL 7.4 server, I’ve had to manually install postgres-9.2.24 because of company procedures and when I’m testing whether the mattermost server works properly, I get the error that it is unable to ping the db :

{“level”:“info”,“ts”:1553271398.8555436,“caller”:“utils/i18n.go:83”,“msg”:“Loaded system translations for ‘en’ from ‘/opt/mattermost/i18n/en.json’”}
{“level”:“info”,“ts”:1553271398.8557446,“caller”:“app/server_app_adapters.go:58”,“msg”:“Server is initial izing…”}
{“level”:“info”,“ts”:1553271398.8631089,“caller”:“sqlstore/supplier.go:215”,“msg”:“Pinging SQL master dat abase”}
{“level”:“error”,“ts”:1553271398.8687565,“caller”:“sqlstore/supplier.go:227”,“msg”:“Failed to ping DB ret rying in 10 seconds err=pq: Ident authentication failed for user “mmuser””}

Now, I’ve checked whether I can connect to the db with psql and I can, but it completely disregards the password I’ve created for mmuser. I can connect to it by typing anything when it prompts me for the pw… I’ve followed every step and modified the json config file and everything.

Thanks for your help.

#2

Hi @shea_bb9,

A response from a community member:

What’s your Mattermost server version? What’s your DataSource configuration value? How did you figure out that Mattermost " completely disregards the password [you]'ve created "?

#3

I’ve installed version 5.9 and the DataSource configuration is this one for postgres :
“DriverName”: “postgres”,
“DataSource”: “postgres://mmuser:innovation123@127.0.0.1:5432/mattermost?sslmode=disable&connect_timeout=10”,

As I said in the post, I’ve tried to connect to the db with psql and typed the wrong password and could still access the mattermost db even when I typed random things instead of the password.