Mattermost Peer-to-Peer Forum

Unable to create user with CLI


I am getting following error when I was trying to create user with cli:

panic: Unable to find i18n directory

goroutine 1 [running]:
main.initDBCommandContextCobra(0x18a2300, 0x10cee40, 0xc421163380)
        /var/lib/jenkins/jobs/msr/jobs/d/jobs/enterprise-release/workspace/src/ +0xcc
main.userCreateCmdF(0x18a2300, 0xc420019f80, 0x0, 0x6, 0x0, 0x0)
        /var/lib/jenkins/jobs/msr/jobs/d/jobs/enterprise-release/workspace/src/ +0x43*Command).execute(0x18a2300, 0xc420019e60, 0x6, 0x6, 0x18a2300, 0xc420019e60)
        /var/lib/jenkins/jobs/msr/jobs/d/jobs/enterprise-release/workspace/src/ +0x3f8*Command).ExecuteC(0x189fee0, 0x18a2960, 0x0, 0x0)



Hi @azizzainul,

Thank you for your report,

Our devs are aware of this issue and there is a ticket to deploy a fix soon.


I think I ran into a similar problem. Whatever I execute with the CLI (even if it is just platform version) I get:

panic: Unable to find i18n directory

goroutine 1 [running]:
main.initDBCommandContextCobra(0x2001d20, 0xc420205c38, 0x3, 0x3)
	/var/lib/jenkins/jobs/msr/jobs/d/jobs/team-release/workspace/src/ +0xe2
main.searchUserCmdF(0x2001d20, 0x2038168, 0x0, 0x0, 0x0, 0x0)
	/var/lib/jenkins/jobs/msr/jobs/d/jobs/team-release/workspace/src/ +0x43*Command).execute(0x2001d20, 0x2038168, 0x0, 0x0, 0x2001d20, 0x2038168)
	/var/lib/jenkins/jobs/msr/jobs/d/jobs/team-release/workspace/src/ +0x475*Command).ExecuteC(0x2005320, 0x20011e0, 0x2001420, 0x2001660)
	/var/lib/jenkins/jobs/msr/jobs/d/jobs/team-release/workspace/src/ +0x30e*Command).Execute(0x2005320, 0xc420101f70, 0xf067ad)
	/var/lib/jenkins/jobs/msr/jobs/d/jobs/team-release/workspace/src/ +0x2b
	/var/lib/jenkins/jobs/msr/jobs/d/jobs/team-release/workspace/src/ +0x2d

Running Mattermost Version 4.7.0
I was already able to use the CLI (permanently deleted a user) before (also already on 4.7.0).


P.S. Can this be solved our should I revert my server to a snapshot, where this was still working?


Hi @isdneuroimaging,

Thanks for your feedback,

We have a ticket here to fix the issue. I’ll request that the fix be prioritized.



FYI, for anyone bouncing against this; the issue is that the cwd is not the mattermost/bin folder. Just cd to that folder and then execute the command and everything should work.