We're Hiring!

Mattermost, Inc.

Unable to access Plugin Marketplace

Problem

Accessing the Plugin Marketplace shows the following error on the UI:

Environment

Mattermost Server 5.27.X, 5.28.X

Diagnosis

The following error is observed in the mattermost.log when the issue is reproduced, indicating an issue with the public key certificate (x509):

{"level":"error","ts":XXXXXXX.XXXXXXX,"caller":"mlog/log.go:190","msg":"Failed to get plugins from the marketplace server.","path":"/api/v4/plugins/marketplace","request_id":"XXXXXXXXX","ip_addr":"XXX.XXX.X.XXX","user_id":"XXXXXXXXXX","method":"GET","err_where":"getRemotePlugins","http_code":500,"err_details":"Get \"https://api.integrations.mattermost.com/api/v1/plugins?build_enterprise_ready=true&enterprise_plugins=false&filter=&local_only=false&page=0&server_version=X.XX.X\": x509: certificate has expired or is not yet valid: current time XXXX-XX-XXTXX:XX:XX is after XXXX-XX-XXTXX:XX:XX"}

Cause

Based on the plugin signing documentation:

Plugins installed via the Plugin Marketplace must be signed by a public key certificate trusted by the local Mattermost server.

Checking through the UI / config.json, the RequirePluginSignature was set to false.

Resolution

Set the Require Plugin Signature to true and click on Save:

If you prefer the config.json, look for RequirePluginSignature and set it to true.

1 Like