Mattermost, Inc.

TLS Connection Error SendMail tls: first record does not look like a TLS handshake

I created an IAM User with SES access for SMTP in AWS. Even the test email fails with the following error.

{“level”:“error”,“ts”:1557817125.2576823,“caller”:“web/context.go:52”,“msg”:“Connection unsuccessful: SendMail: Failed to open TLS connection, tls: first record does not look like a TLS handshake”,“path”:"/api/v4/email/test",“request_id”:“XXXnpxm97ffhzp9cgixiXXXXX”,“ip_addr”:“157.37.133.140”,“user_id”:"",“method”:“POST”,“err_where”:“testEmail”,“http_code”:500,“err_details”:""}

Enabled SMTP Auth is set to true
SMTP server: email-smtp.us.east-1.amazonaws.com
SMTP port: 587
SMTP username: User access_key
SMTP Password: secret_key
Connection is TLS

iam policy attached is

{
    "Version": "2012-10-17",
    "Statement": [
        {
            "Sid": "VisualEditor0",
            "Effect": "Allow",
            "Action": [
                "ses:SendEmail",
                "ses:SendRawEmail"
            ],
            "Resource": "*"
        }
    ]
}

Mattermost Versions Test: 5.10, 5.9.1

Hi @marutinandanpandya,

Wondering if this previous thread might help: [solved] TLS Connection Error SendMail Failed to Open TLS - on SES Amazon SMTP credentials in Config/Mattermost JSON?

Nope. Already saw that.
As the person mentioned he was testing with the wrong creds and fixing the creds solved the issue.

Same is not the case here, I created the IAM User specifically with SES access and yet the issue. (Also tried sending emails with user having administrative access, yet the same issue)

Hi @marutinandanpandya, can you try using port 456 or 2456?