Mattermost, Inc.

Team Edition Server v3.3.0 [EROR] /api/v3/users/status: code=404

Hi,

First, i have to say. Very happy and grateful of your product. I never had any issue of what so ever with it.
But after upgrading to team edition v3.3.0 ( from v3.2.0) , i get a lot of errors in mattermost.log every seconds.

[EROR] /api/v3/users/status: code=404 ip=10.126.1.16
[EROR] /api/v3/users/status: code=404 ip=10.126.1.5
[EROR] /api/v3/users/status: code=404 ip=10.126.1.8

One for each client connected to mattermost with native app (windows+Osx) or web browser.
I’m running RHEL7 + mattermost v3.3.0 + postgres 9 + Nginx with sll mode.

Can it be the new API update 3.3 with my basic nginx configuration?
Here my nginx config. for mattermost:

server {
listen 80;
server_name mattermost.sll.se;
return 301 https://$server_name$request_uri;
}

server {
listen 443 ssl;
server_name mattermost.sll.se;

ssl on;
ssl_certificate /etc/nginx/conf.d/mattermost.pem;
ssl_certificate_key /etc/nginx/conf.d/mattermost.key;
ssl_session_timeout 5m;
ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
ssl_ciphers ‘EECDH+AESGCM:EDH+AESGCM:AES256+EECDH:AES256+EDH’;
ssl_prefer_server_ciphers on;
ssl_session_cache shared:SSL:10m;

location / {
gzip off;
proxy_set_header X-Forwarded-Ssl on;
client_max_body_size 50M;
proxy_set_header Upgrade $http_upgrade;
proxy_set_header Connection “upgrade”;
proxy_set_header Host $http_host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Forwarded-Proto $scheme;
proxy_set_header X-Frame-Options SAMEORIGIN;
proxy_pass http://127.0.0.1:8065;
}
}

Please mattermost, any help with that will be much appreciate.
I’m sure it’s some bad configuration between new API v3 and NGINX.

Hi guys,

Can we have a quick fix with like mattermost-team-3.3.1 for this ?
Or an install guide updated with the configuration to have in nginx and api v3 GET ?

Because i’m pretty sure is the relation between nginx and the new GET in api-v3.

thanks a lot

Just upgraded - we experience the same problem - same setup. Did you solve it?

No I’m still waiting an officiel answer from mattermost team.
But since 2 days. Silence

RELEASE note i v3.3.0

API Changes from v3.2 to v3.3
Updated admin routes:

Changed users/status from POST to GET

Upgraded to 3.3.0, same problem.

What versions of the clients do you use? I only get this error on my Linux client. OS X, Windows, iOS and Web are looking fine. All desktop clients are 1.3.0 (most current).

Also, do you get a “We received an unexpected status code from the server. (404)” too at the top of the client, and the status icons have disappeared?

My nginx config is very similar, and, as most of my clients do work fine, i don’t think it’s an nginx problem at all.

I most likely will open a support case as we use the enterprise version. Hope they will answer quicker then…

Hmmm, just 30 seconds after i sent my last post, my Linux client (which has the problem) showed me that my session has expired. Reloaded it using Ctrl+Shift+R (Cache!!), logged in again, and the problem is gone. Seems it caches some stuff and therefore tries query the wrong URL.

Please try if that solves it for you too.

I agree, it’s okey after multiple restart.

Still have som users/ip showing errors in logs because folks are not back from holidays.

There is a post of Matttermost today, about a new desktop app with a fix about this cache-problem.
here: 404 error messages for /api/v3/users/status

thank for your help anyway !