Mattermost, Inc.

"Switch to..." menu option shows team URL name instead of team name when switching teams

Is this normal, that other discusions that I’m part of are displayed as random URL ascii text?

I wold say not :wink: Any one experincing this problem ? (suing: gitlab-ce-8.1.0-ce.1.el7.x86_64)

Best regards,
Krzysztof

Hi @kmazurek,

In GitLab 8.1 the menu shows “Switch to [TEAM_URL_NAME]”, so my guess is that either the teams listed were created with random input, or perhaps they were programatically created,

You can verify by switching to the team and then looking at the URL to see if it matches what you expected?

Since GitLab 8.1 shipped, there’s been an update so the menu will show “Switch to [TEAM_NAME]” in future releases,

Exactly https://my_host_here/aie7pdf6ipbyucjt1u7qqc4a1a/channels/town-square but as I remember we used to click the “Create New Team with Gitlab Account” on 8.0.4-CE version. There is even >3 characters limit as I remember :wink:

In “Team Settings” the initial typed in name is shown…

I turned on emailing - and I receive:

Finding teams
Your request to find teams associated with your email found the following:
aie7pdf6ipbyucjt1u7qqc4a1a
jjqhhm9q6jy38kin9m1zbntqby
rsdabi6gkbr4bra48adf34arqr
xw5bf7cp4fdi5c4z1tdj1wwfxe
ykn141fqnig75crcoexzsdb51w

As I checked 4/5 are now test-purpous teams/projects (named TEST2 for example). How can I delete then - I don’t see a Remove/Delete option in menu.

I’d like to dive in here with the question of why the team-url is not customizable when created via a GitLab authenticated user.
It seems to me only as an email user do i get to set up both the full team name and the team url.
Are there plans to change this? Or am I missing something?

Hi @reach3r,

Verified this is the case, when GitLab SSO is used a random URL seems to be generated for the team, looking into why this is…

Hi @it33!
Regarding your original question (before the edit): since I’m not in the office I don’t have the exact URL at hand right now, but in principal it was like this:
As team name I entered “Site Operations & Services” and the URL created was the same but stripped of special characters, something like “site-operations–services”.
This happened when creating a new team without being logged in.

When being logged in and creating a new team the url seems to be a randomly generated string of characters, as you wrote.

Thx for looking into it!

Adding ticket to track the fix for this: https://mattermost.atlassian.net/browse/PLT-916

Also, the original issue on this thread is fixed in v1.2, the team name will be shown in menu, rather than the team URL name

gitlab-ce-8.2.0-ce.0.el7.x86_64 brings the change in GUI. But still in email when you list all the Teams you are in brings he uuid like links.

Thanks for bringing this up, I made an accepting pull requests ticket about the issue.