We're Hiring!

Mattermost Discussion Forums

Support for Extended Support Release 5.31 Is Ending Soon

v5.37 has been implemented as a new Extended Support Release on July 16, 2021. v5.37 will be supported until April 15, 2022.

We have been maintaining v5.31 as our current ESR. This version is coming to the end of its life cycle. Starting October 15, 2021 we will no longer be backporting fixes to v5.31. Please upgrade your systems to v5.37 as soon as possible to continue to receive important bug fixes and security updates and to maintain mobile compatibility.

Extended Support Releases or ESRs are intended for organizations who value stability over having the newest features and improvements, or for organizations who have a long internal testing and certification process to undergo when upgrading.

To receive future updates on when the next ESR is available, sign up for our mailing list here.

2 Likes

Hi, I’m new here and hope this is in the right place.

I have the ESR v5.31.6 with mysql on Ubuntu 18.04. I want to upgrade to ESR v5.37, but I’m seeing messaging which appears to be in conflict. Examples:

From the upgrade docs I see the note at the bottom that says:

We only support one minor version difference between the server versions when performing a rolling upgrade (for example v5.27.1 + v5.27.2 or v5.26.4 + v5.27.1 is supported, whereas v5.25.5 + v5.27.0 is not supported).

But I also see in the version archive that there is no dot-dot version available for download between my ESR version (5.31.6) and the latest dot-dot release in the archive (5.31.9). Am I hosed? How can I get to from 5.31.6 to 5.31.9 if that is required, if that is what is meant by the “one minor version difference between the server versions” in the quote above?

Additionally, I saw in the ESR page of the docs that

There will be a clear upgrade path provided between ESR versions.

So, my questions are:

  1. Can I skip from ESR to ESR?
  2. If yes, do I have to get from v5.31.6 to 5.31.9 for that?
  3. If yes, how do I do that, since the 5.31.7 and 5.31.8 versions are not in the versions archive?
  4. Where is this clear upgrade path mentioned on the ESR page?

I am a big fan of Mattermost. Thanks for making it available.

cliff1976

We have opened a doc PR to clarify the upgrade notes and will post here an update once it is reviewed https://github.com/mattermost/docs/pull/4943.

1 Like

Upgrading Mattermost Server — Mattermost documentation is now updated. You can upgrade from an ESR to the next ESR version, but you should review the Important Upgrade Notes for all intermediate versions in between to ensure you’re aware of the possible migrations that could affect your upgrade.

1 Like

TYVM!
I’ll give it a try tomorrow morning.

Me again.

I couldn’t leave it alone and started looking at this again today. Hate to nag, but I wonder if there is still something amiss. And my apologies if it’s just me (it might well be).

TL;DR: does the sentence from Step 7 ending in “you can jump to step 8 below.” need to disappear? I think if it doesn’t, lots of important stuff won’t be copied that should be.

I see in Step 7 the following:

Run ls on your Mattermost install directory to identify what default folders exist. If your folders match the structure specified in the following note, you can jump to step 8 below.

OK, cool, that is my situation.

And then Step 8 tells me:

The n (no-clobber) flag and trailing . on source are very important. The n (no-clobber) flag preserves existing configurations and logs in your installation path. The trailing . on source ensures all installation files are copied.

Curious, I compare (for example) the contents of /tmp/mattermost-upgrade/bin/ with /opt/mattermost/bin/ and I find among the upgrade files:

root /tmp/mattermost-upgrade/bin# ls -alht
total 110M
drwxr-xr-x 10 root root 4.0K Aug 13 16:04 ..
drwxr-xr-x  2 root root 4.0K Jul 29 13:38 .
-rwxr-xr-x  1 root root  89M Jul 29 13:38 mattermost
-rwxr-xr-x  1 root root  22M Jul  6 15:46 mmctl

…and among my existing files:

root /opt/mattermost/bin# ls -alht
total 108M
drwxr-xr-x 12 mattermost mattermost 4.0K Jul 29 13:37 ..
drwxr-xr-x  2 mattermost mattermost 4.0K Jun 10 13:53 .
-rwxr-xr-x  1 mattermost mattermost  85M Jun 10 13:53 mattermost
-rwxr-xr-x  1 mattermost mattermost 2.2M Jun 10 13:53 platform
-rwxr-xr-x  1 mattermost mattermost  21M Jan 13  2021 mmctl

Uh-oh. I don’t have to erase the old files, since my files and folders match the default, as described in Step 7. But I also won’t replace the old files with the ones from /tmp/mattermost-upgrade because of the -n noclobber option in Step 8.

I haven’t tried these steps yet – it’s all a mental walk-through at this point.

TL;DR: does the sentence from Step 7 ending in “you can jump to step 8 below.” need to disappear? I think if it doesn’t, lots of important stuff won’t be copied that should be.

Feel free to open a docs issue Issues · mattermost/docs · GitHub for any findings.

Done. My first issue on GitHub EVAR! Thanks for the motivation!

1 Like