Mattermost, Inc.

[SOLVED] Why is upload plugin disabled?

My upload plugin button seems to be disable, running absolute latest docker-compose image and ubuntu image with an E10 license.

image

image

Any idea why the button is disabled?

OK I figured it out in config.json change PluginSettings EnableUploads from false to true

In the default install this lives in /opt/mattermost/config

Just in case someone ends up here like me, here are a few more details.

The “Upload Plugin” was disabled despite choosing “Enable Plugins” as true on System Console. In order to enable plugin uploads, you have to edit your mattermost installation’s config.json. Specifically this entry:

"PluginSettings": {
        "Enable": true,
        "EnableUploads": true,
        "Directory": "./plugins",
        "ClientDirectory": "./client/plugins",
        "Plugins": {},
        "PluginStates": {
            "jira": {
                "Enable": true
            }
	}
}

When you do the “Enable Plugins” as true on System Console, it only sets the "Enable" value to true in the config above. To Enable upload, you have to manually edit the config and set "EnableUploads" as true.

The steps I followed are:

  1. If you installed mattermost on your local machine as suggested in the tutorial here https://docs.mattermost.com/install/docker-local-machine.html by doing docker run --name mattermost-preview -d --publish 8065:8065 --add-host dockerhost:127.0.0.1 mattermost/mattermost-preview'), then first access your local docker mattermost installation using:

docker exec -ti mattermost-preview /bin/bash.

  1. Navigate to the config directory within:
$ docker exec -ti mattermost-preview /bin/bash
root@4bdee6a90b82:/mm# ls
docker-entry.sh  mattermost-data
mattermost	 mattermost-team-5.1.0-linux-amd64.tar.gz
root@4bdee6a90b82:/mm# cd mattermost/config/
root@4bdee6a90b82:/mm/mattermost/config# ls
README.md  timezones.json
config.json  config_docker.json  default.json
  1. (at this point I installed emacs to edit the config, but you do you :slight_smile: ) Here, although you see a config.json, changing the Plugin settings there won’t help. I don’t know the reason why, but if you want to enable plugin uploads, then open up config_docker.json and change "EnableUploads" as true. Save and you’re done. Refresh your mattermost client and you should see “Upload Plugin” enabled in your system console.

Cheers!

5 Likes

Hey, i created a mattermost server using heroku, how do i setup these things for heroku server?