[Solved] Unable to join teams


#1

Greetings,

We are using Gitlab (Paid Enterprise Edition version; also confirmed on my home private Gitlab Community Edition) with Mattermost and we want the only authentication to be Gitlab. I am running the latest version of Gitlab which I believe is running the latest 4.8.1. I had a user contact me with an oddity that I have confirmed with my test account (regular user) and my admin account. I am not sure when this problem started as we’ve been running the same config for a few months.

The short of the problem is that users are unable to join teams. There is no + button on the team side bar for them to click on. For Admin users there is, but it ONLY allows team creation (which we only want Admins creating teams - but there is no way for them to join a team with the + icon).

So as an Admin, I create a new team and make it public for anyone…but then no one can join it because they don’t have a button to click on. Fine. I will send out the links to join the team. A user clicks on it, and they are immediately redirected to their primary team! They never join the new team. No error that I’ve seen either.

Worse, we had a user who WAS on a team, but in a “I wonder what happens if…” moment removed himself from the team and now we can NOT seem to get him back into that team. I’m at a loss. Any help or suggestions would be appreciated. Thanks!

Here is the Gitlab config:

mattermost[‘env’] = {
‘MM_SERVICESETTINGS_ENABLECUSTOMEMOJI’ => ‘true’,
‘MM_SERVICESETTINGS_ENABLEEMOJIPICKER’ => ‘true’,
‘MM_EMAILSETTINGS_ENABLESIGNUPWITHEMAIL’ => ‘false’,
‘MM_EMAILSETTINGS_ENABLESIGNINWITHEMAIL’ => ‘false’,
‘MM_EMAILSETTINGS_ENABLESIGNINWITHUSERNAME’ => ‘false’,
‘MM_EMAILSETTINGS_ENABLEEMAILBATCHING’ => ‘true’,
‘MM_EMAILSETTINGS_SENDEMAILNOTIFICATIONS’ => ‘true’,
‘MM_EMAILSETTINGS_USECHANNELINEMAILNOTIFICATIONS’ => ‘true’,
‘MM_EMAILSETTINGS_REQUIREEMAILVERIFICATION’ => ‘false’,
‘MM_EMAILSETTINGS_FEEDBACKNAME’ => ‘Removed’,
‘MM_EMAILSETTINGS_FEEDBACKEMAIL’ => ‘Removed’,
‘MM_EMAILSETTINGS_ENABLESMTPAUTH’ => ‘true’,
‘MM_EMAILSETTINGS_SMTPUSERNAME’ => ‘Removed’,
‘MM_EMAILSETTINGS_SMTPPASSWORD’ => ‘Removed’,
‘MM_EMAILSETTINGS_SMTPSERVER’ => ‘Removed’,
‘MM_EMAILSETTINGS_SMTPPORT’ => ‘587’,
‘MM_EMAILSETTINGS_CONNECTIONSECURITY’ => ‘STARTTLS’,
‘MM_TEAMSETTINGS_ENABLETEAMCREATION’ => ‘false’,
‘MM_TEAMSETTINGS_ENABLEUSERCREATION’ => ‘false’
}


#2

An update.
I upgraded to Gitlab 10.7.2 which just came out. Same bug.
I disabled every Mattermost config option I had set in the gitlab.rb file except to enable Mattermost. Same bug.

I was able to get a hold of an admin who was still in that guys group who was able to add him manually. Hooray!

But that doesn’t solve the issue of why users/admins have no way to join a team otherwise. :-/

Help please!


#3

Hi @stack,

Thanks for your feedback,

Are the users able to join another team by clicking on Main Menu (hamburger) > Join Another Team ?

We did have a bug in 4.8 where users couldn’t join a team but that was fixed in 4.9 (which isn’t bundled with GitLab yet I believe)…


#4

Thank you for replying. I do not have that. Here is the shot as an admin. As a user there are less options.

[Edit] Just to confirm, it appears that the MM version is 4.8.1.


#5

Thanks for the additional information @stack,

Could you help send a screenshot of your “About Mattermost” screen (from main menu / hamburger)? This will give us information on the database, etc. to help troubleshoot.


#6

Sure. I’d be happy too! This is from my personal Gitlab CE version but the EE should be the same.
Screenshot%20from%202018-05-03%2016-50-04


#7

I also just found out that May 22 is when Gitlab is scheduled to release Mattermost 4.9. It would be nice to confirm if the same bug you mentioned before is actually the issue I am seeing. Because if it is already fixed, then I just need to wait a few weeks patiently. :slight_smile:
However, I would be sad if we waited and the bug wasn’t the one I’m seeing. :-/

If you have any suggestions or need me to try something, I am happy to do so.

Thank you!


#8

Thanks @stack :slight_smile:

I’m going to pass the screenshot information to a colleague to see whether we can determine anything further regarding your issue with the database you’re using.

The bug I mentioned in 4.8 was on Mattermost enterprise edition so I don’t think it’s related :frowning:

I’ll post back here with feedback as soon as I can…


#9

Hi @stack,

Apologies for the delay in getting back to you… We’re still investigating / trying to reproduce your issue…


#10

Hi @stack,

We’ve been trying to reproduce your issue on one of our test servers running Mattermost 4.9

Can you confirm that these reproduction steps are correct?

I set up my test server with your setup leaving the SMTP stuff with our config settings…

When clicking on the GitLab icon to log in:

  1. I got the authorisation page for the test server to authorise GitLab

  2. Copying your config and disabling signupwithemail, signinwithemail and signinwithusername, I got an error user creation is disabled!

  3. So I went back to the Sys Console and set “Users & Teams” > “Enable Account Creation” to “True” and then I was able to continue and get to the “Choose a Team to Join” page.

  4. As I was a team admin on that team, I created another GitLab account, then logged into MM with that user using GitLab and I got the authentication page to authorise GitLab to the test server and I was then logged in.

  5. I cannot reproduce your issue of users not being able to join a team. I see the option in the main menu dropdown to “Join another team”.

Can you help share:

  1. Server logs when someone tries to join a team and it fails
  2. Javascript Console errors when someone tries to join a team and it fails

Also, GitLab 10.8 RC runs Mattermost 4.9 so you could try downloading this version of GitLab to see if it resolves your issue?


#11

@stack Just to confirm, have you made the team joinable by any user in the Team Settings? Hopefully I’m not repeating something you’ve already answered


#12

Thank you @lindy65 for all of your work and effort. It is very appreciated!

I too was unable to reproduce on a fresh build. So I rebuilt my Gitlab server (super simple since I use their omnibus) and now @hmhealey’s post works for me. When selected to ‘Yes’ users are able to join teams. Previously I had this set to ‘Yes’ but users never saw the ‘+’ symbol.

Unfortunately, my home server which I had thought I had reproduced the issue…well, I forgot to test the Yes/No option. So I never actually reproduced the problem like I thought I had. :frowning:

I wish I had done more to capture information. I apologize for that.
But I’m glad that this is working again! :smile:


#13

Fantastic news @stack!

Very pleased your issue is resolved :blush: