We're Hiring!

Mattermost, Inc.

[SOLVED] Unable to enable link preview in system console

Summary

When enabling link preview in system console and applying the radio button return to disabled state

Steps to reproduce

System Console > link previews > yes > save

Expected behavior

It should stay on yes

Observed behavior

There is no error message, nothing in logs

Hi @MattMattV,

Thanks for your report. I’m not able to reproduce the issue and changing the link preview settings in system console works fine.

Can you share which version of Mattermost you’re using? Perhaps you could try updating to the latest version released on March 16th and let us know if the issue still persists for you?

I just upgraded to 3.7.2 and the issue persists. :disappointed_relieved:

Hi @MattMattV,

Could you share more about your environment so we can better try to reproduce the issue on our side?

I followed the install guide on an Ubuntu 16.04.2 LTS host from OVH, I also followed the guide to use nginx as a reverse proxy + let’s encrypt automation.

If it can help I can provide a System Admin accont since my server is not sensitive at all, it may be easier to debug and see what’s going on.

Thanks @MattMattV,

I’ll ask one of our technical support people to have a look at this issue and post back here with some suggestions for you!

@MattMattV Does the issue reproduce for any other System Console settings, or only for Link Previews?

Also, which of the two Mattermost versions did you install:

  • Team Edition: https://releases.mattermost.com/3.7.2/mattermost-team-3.7.2-linux-amd64.tar.gz
  • Enterprise Edition: https://releases.mattermost.com/3.7.2/mattermost-3.7.2-linux-amd64.tar.gz
ls -la config/config.json

Is the file owned by the same user the process platform is using to run?

Perhaps you are running it with an unprivileged user while the config.json file is owned by root which would not let you change the file itself.

The problem was the permissons ! I chown the file and the issue was gone, thank you @prixone !

You’re most welcome :slight_smile: glad I was able to help…