[SOLVED] Troubleshooting "There was a problem connecting the video call." errors


#22

I have still the same issue with the docker image. When I try to start it, it seems to just stops because of the STUN server.


Starting Meetecho Janus (WebRTC Gateway) v0.2.2

Checking command line arguments…
Debug/log level is 4
Debug/log timestamps are disabled
Debug/log colors are enabled
Adding ‘vmnet’ to the ICE ignore list…
Using 172.17.0.2 as local IP…
Token based authentication enabled
Initializing ICE stuff (Full mode, ICE-TCP candidates disabled, IPv6 support disabled)
STUN server to use: stun.l.google.com:19302
ICE handles watchdog started
Testing STUN server: message is of 20 bytes
[FATAL] [ice.c:janus_ice_set_stun_server:770] No response to our STUN BINDING test
[FATAL] [janus.c:main:3554] Invalid STUN address stun.l.google.com:19302


#23

So in order to make it work you definitely need to set a STUN server in the janus conf, it does not have to be the google one it can be any STUN server as long as you can have access to, please ensure that you can actually reach the STUN server from the Janus box (webrtc docker image or manual installation of janus)


#24

Having trouble setting up WebRTC as well :frowning:

  1. I used Mattermost Docker preview.
  2. Using Mattermost 4.0.0 with mysql database.
  3. Tried Firefox (54), Chrome (57) and Mattermost desktop for linux (3.7.0).
  4. Yes.
  5. Each time.

All we get is the “There was a problem connecting the video call.” error. We can see our selves in the window but there is no video or audio with the other side.


#25

Hi @cilamich,

Would you be so kind to open the javascript console and share the errors that appear there when you try to connect to the other peer?

I just eant to nake sure that you MM instance is actually connecting to the janus server


#26

Hi,

I am also facing the same problem. I was able to install the docker succesfully and Webrtc is configured on the server as well as the End user profile. But i am getting this error There was a problem connecting the video call.


#27

Hi,
I tried many setup but none seems to work

  1. Used both docker preview for WebRTC and my own janus setup. I didn’t setup STUN/TURN

  2. I have mattermost 4.0.2 on Debian 8 usng Postgresql running via systemd service. Mattermost is behind a proxy which do SSL termination

  3. I tried both Chorme and Firefox on Ubuntu 16.04 and Windows10 (latest available version)

    1. THe issue reproduce for every user each time a call is started

I also checked logs for all entities

  1. In browser console nothing appears

  2. In mattermost logs (debug) I see many call but not error. I see also some /api/v3/users/websocket:webrtc
    request

  3. I janus logs I see the token request successfull

Got an admin/monitor HTTP POST request on /admin…
[transports/janus_http.c:janus_http_admin_handler:1483] … Just parsing headers for now…
[transports/janus_http.c:janus_http_headers:1734] Host: PUBLIC_HOSTNAME:7889
[transports/janus_http.c:janus_http_headers:1734] User-Agent: Go-http-client/1.1
[transports/janus_http.c:janus_http_headers:1734] Content-Length: 179
[transports/janus_http.c:janus_http_headers:1734] Content-Type: application/json
[transports/janus_http.c:janus_http_headers:1734] Accept-Encoding: gzip
[transports/janus_http.c:janus_http_admin_handler:1590] … parsing request…
Processing POST data (application/json) (179 bytes)…
[transports/janus_http.c:janus_http_admin_handler:1640] – Data we have now (179 bytes)
[transports/janus_http.c:janus_http_admin_handler:1590] … parsing request…
Processing POST data (application/json) (0 bytes)…
[transports/janus_http.c:janus_http_admin_handler:1645] Done getting payload, we can answer
{“admin_secret”:“XXXXXXXXXXXXXXXXXXXXXXXXXXX”,“janus”:“add_token”,“token”:“eWRjNWdnc3JwN2Z0M2JlZzE0Y3FpaThvOG8=”,“transaction”:“9tyi93jkmjdjzge9gtbngg61ae”}
Forwarding admin request to the core (0x7fd220001e60)
Got an admin API request from janus.transport.http (0x7fd220001e60)
Transport task pool, serving request

My setup is as follows

  1. janus installed on a public host, no proxy, no nat
  2. mattermost running on a public host behind reverse proxy (ssl termination)
  3. client via browser on a private LAN (nat)

Should I setup TURN/Stun?


#28

I’m going to write a doc on how to successfully configure webrtc sometime next week and see if that helps.


#29

Thank you @elias

Do you have a working public setup?


#30

@andreacappelli yup https://pre-release.mattermost.com


#31

Did you write a doc on how you setup the webrtc server?


#32

Documentation was updated here: https://docs.mattermost.com/deployment/webrtc.html


#33

HI,have you resolved this problem now?


#34

just follow the guide from: https://docs.mattermost.com/deployment/webrtc.html


#35

I have the same setup, have you been able to run behind a proxy?