We're Hiring!

Mattermost, Inc.

[Solved] Tried everything and still can't get SMTP working

i’ve tried all sorts of settings. here’s a reply from our other hosting company (who we’re using for our mail)

If you are required to use an SSL connection you would wan to use the settings I will include below. You may also want to check with them to make sure they are not having an issue with the SSL certificate used for the mail services. We use a self-signed certificate which on some services produces a warning I am not familiar with mattermost enough to say however this should be a fairly quick question for them to answer.

please can someone help this is proving to be a very troublesome setup

Hi @AndyatFocallocal,

Mattermost will accept self-signed certificates for SSL SMTP connections, so that should not be the problem. It sounds like the server you’re hosting Mattermost on might be blocking certain ports. Can you confirm to make sure the SMTP port you’re setting in your Mattermost config is open on your server/firewall?

1 Like

thanks very much that seems like it was the issue. there was a default block on our server which they’ve removed …although mattermost didnt restart with the server and throws an out of memory error when i try to restart it via our console

1 Like