[SOLVED] Three second channel switching latency


Some of our Windows 10 64-bit desktop app users are intermittently seeing 3 seconds latency while switching channels. They click to one channel and count out loud to three (one one-thousand…) and then it switches.

We are running Mattermost 4.4.0 and on 3.7.1 desktop app. We have around 65 people using the system. Mattermost behind Nginx with PostgreSQL is deployed on a NixOS virtual machine guest on Hyper-V. I’ve allocated 2 GB of RAM and 4 processors to the VM. htop does not show any RAM or CPU resource exhaustion during times when the latency strikes (or any other times). The load average is 0 and only 325 GB of RAM are allocated on the entire system.

Do other people seen this issue? Does anyone have suggestions for how to track down performance issues like this? Is there some logging options I could enable in mattermost or nginx to help?


Hi @ryantm,

Thanks for your feedback,

Are you running Mattermost team or enterprise edition?


We are running team edition.


Hi @ryantm,

Thanks for your response,

There is in-depth performance monitoring in enterprise edition but let me check with out devs how you could go about monitoring performance in the team edition.


It looks like version 4.6.0 addressed this issue; thanks!



I am facing same issue in Mattermost v4.6.1

Earlier we had Mattermost on v3.8 which was updated to v4.2 and now we did upgrade to v4.6.1
Before this Channel switching was instant but now there is lag of 2-3 seconds after which Chat appears.

Issue is there in Desktop Application as well as if we use via browser (Chrome).


I’ve also had a few reports of continued lag when switching channels with my 60-person deployment. I am trying to upgrade everyone to the 4.0.0 desktop release version to see if that helps. There isn’t any change-log message about it helping though.


Mine was working fine till v4.2

After upgrading to v4.6.1, lag is quite evident.


Hi @yatin @ryantm,

There have been quite a few performance improvements since v4.6.2 which will release today (2/16) in v4.7

Let us know if your issue is resolved after upgrading?


Thanks for the update.

I’ll plan the server upgrade in next few days.


We’re experiencing the same issue on Mattermost 4.7.0 and the Windows app, version 4.0.0. After poking at the server and seeing it basically idling with less than half its RAM used, I just fully exited and re-opened the desktop app and things went back to normal.

It appears to be the app that’s developing the lag after being open for an extended period rather than anything to do with the server.


When running Mattermost 4.7.2 and the 4.0.0 Windows app, I noticed the same problem, where switching channels got very slow (3+ seconds to switch) after running for a long time. “View -> Clear Cache and Reload” fixed it for me.