Mattermost, Inc.

[Solved] "The redirect URI included is not valid." after mmost URL change

Hey, this issue has popped up here and here, but neither have answers that apply to me (I don’t think.)

I don’t have a proxy in place, and I’m at the current version, so I can’t update right now.

GitLab 8.4.4

I changed the url of mattermost from old.mydomain.com to new.mydomain.com in /etc/gitlab/gitlab.rb

mattermost_external_url 'https://new.mydomain.com'

When I go to https://new.mydomain.com/myteam I get directed to the correct "Sign in to myteam on gitlab mattermost ‘with gitlab’ ". When I click Sign in with gitlab, I get directed to the Profile Settings page with this error “An error has occurred, The redirect URI included is not valid.” I did run gitlab-ctl reconfigure after the change to gitlab.rb. Not sure what else I can try right now. Any ideas?

Hi @Slimmons, you will need to do the following to fix your issue:

  1. Login to GitLab as an admin
  2. Go to the “Admin area” and click “Applications” in the sidebar
  3. Next to the application “GitLab Mattermost” or something of similar name, click Edit
  4. Update the URLs you see to match the host of your new mattermost_external_url
  5. Click “Submit”

That should fix your issue. Let me know if it doesn’t work and I’ll help you troubleshoot.

1 Like

Ugh, I forgot all about the applications section. Thanks for the help, that fixed everything!

1 Like