Mattermost, Inc.

[SOLVED] Tcp error at start

Hi mates,

Im configuring mattermost with own SSL certificates (CA signed) but at the configuration I obtain the following error:


[2017/10/30 16:57:26 -05] [INFO] El servidor está escuchando en 8065
[2017/10/30 16:57:26 -05] [CRIT] Error arrancando el servidor, err:listen tcp: address 8065: missing port in address

On the config.json file the port configured is the 8065 with no SSL and no 80 to 443 redirection

On nginx I have upstream backend at 8065 and listen directive for 80 and later for 443 ports.

snip:

upstream backend {
server my_server_name:8065;
}

proxy_cache_path /var/cache/nginx levels=1:2 keys_zone=mattermost_cache:10m max_size=3g inactive=120m use_temp_path=off;

server {

listen 80;
server_name my_server_name;
return 301 https://$server_name$request_uri;
}

server {
listen 443 ssl http2;
server_name my_server_name;


"

I can’t find the solution, please I’d appreciate any help.

Thanks in advance.

Hi @ellanosv,

Thanks for your feedback,

Perhaps this documentation will be helpful?

@ellanosv I suspect that you have an error in your config.json. What is the value of your ServiceSettings.ListenAddress config setting? The format of this setting should be [ip address]:[port]. Both ip address and port are technically optional, but the colon separator is not.

From the error message that is printed, my guess is that you have it set to “8065” and not “:8065”.

Thanks both for your replies. The error indeed was in the json file for I omitted the colon, my bad.

Now it is working like a charm.

Thank you very much

Thanks @ellanosv,

Glad your issue is resolved :slight_smile: