[SOLVED] Self hosted push notifications


#1

Hi,

I can’t get working self hosted push notification for my android phones…
Could you give me directions, what’s missing?

What I did:

  • Mattermost: 4.3.0 (self hosted - container)
  • Mattermost push-proxy: (self hosted, container) communicates via docker0 interface
  • mattermost-mobile:
    • replaced android/app/google-services.json (downloaded from firebase console)
    • modified: <meta-data android:name=“com.wix.reactnativenotifications.gcmSenderId” android:value= <- my gcmSenderID

my push proxy config contains only android specific parts:

{
“ListenAddress”:":8066",
“ThrottlePerSec”:300,
“ThrottleMemoryStoreSize”:50000,
“ThrottleVaryByHeader”:“X-Forwarded-For”,
“EnableMetrics”: false,
“AndroidPushSettings”:[
{
“Type”:“android”,
“AndroidApiKey”:“xxx”
},
{
“Type”:“android_rn”,
“AndroidApiKey”:“xxx”
}
]
}

AndroidApyKey from Firebase Settings/General/Web Api Key.

In short, I don’t get notifications:
I’ve tested the following ones:
sending notification from firebase console to deviceid/app:
completed, but I didn’t get any notification in application
using mattermost-push-proxy:
error: 401 Unauthorized type=android_rn

Any idea, what’s missing?

Kind regards,
Harald


#2

Hi @dh.harald,

Thanks for your feedback,

You don’t say whether you’ve configured your system using guides from our documentation so I’m listing a couple of help docs here. If these don’t help, please come back and we’ll try to troubleshoot further?

You might also like to upgrade to the latest version of Mattermost as there have been quite a few updates since 4.3


#3

I’ve solved this issue, but I don’t know, what was the real solution…
I started everything from scratch:

Kind regards,
Harald


#4

Pleased you have resolved the issue @dh.harald :slight_smile: Thanks for posting back your steps to your success…