[SOLVED] Port Forwarding when upgrading to Enterprise 4.9.2


#1

I just upgraded from Enterprise version 4.8.0 to 4.9.2, and found a small issue in the documentation. Our installation was using a proxy, but when I did the upgrade and copied over the config as described in the upgrade directions, I couldn’t restart the service via systemctl because the Forward80To443 was set to true. The error message in the journal made it easy to identify and was a quick fix, but it might be useful to give others a heads up in the upgrade notes to minimize downtime while upgrading.


#2

@ddrum001 Thank you for reporting this! Can you help attach a link to the documentation and I will help update it.


#3

Thanks @amy.blais - the general upgrade steps are here:

https://docs.mattermost.com/administration/upgrade.html#upgrade-enterprise-edition

and the likely place to note it is in the Upgrade Notes, here:

https://docs.mattermost.com/administration/important-upgrade-notes.html

Let me know if I can help in any other way,
David


#4

@ddrum001 I took a look at the documentation and in the Upgrade Notes there is a note for v4.6.2 saying that “If Let’s Encrypt is enabled, forward port 80 through a firewall, with Forward80To443 config.json setting set to true to complete the Let’s Encrypt certification.”

Does this refer to the issue you were seeing while upgrading? If not, I will definitely update the documentation!

I am not a developer so I apologize beforehand if the question seems silly :slight_smile:


#5

@amy.blais Yeah, I suppose that applied to me since I was using Let’s Encrypt.

However, I was coming from version 4.8.0, so I didn’t look at that note. More so, I had to change that setting to false, which is the opposite of what that note seems to be saying. I don’t recall the exact state of this setting before the change, so it’s probably not worth it to change the documentation, just yet.

With that said, I’ll likely upgrade to 4.10.0 soon, so I’ll see if there is a similar issue, and be careful to document it.


#6

@ddrum001 Thank you for this information, I will check with our team to see if there is anything to update / any mistakes in the documentation!


#7

Thanks for raising this confusion to our attention, @ddrum001!

I’ve pushed a proposed documentation change to https://github.com/mattermost/docs/pull/2029 that clarifies this. Would the text there have addressed your confusion?


#8

@jesse yes, that’s perfect. Thanks for the help!