[SOLVED] Plugins on Windows Deployment


#1

Got a Team-Edition Deployment on Windows working - mostly.

But for Plugins I get the following error:
[EROR] failed to start up plugins: mkdir ./client/plugins: The system cannot find the path specified.

IMO this has to do with how the windows service is programmed.
The “AppDirectory” - per default - is using …/bin/

I am not sure if overwriting in the registration or the via startup parameter helps.

Can anyone comment on this behavior?

Thank you in advance,
Martin


#2

Hi @zwiglm,

Thanks for your feedback,

Perhaps this plugin documentation will be of assistance?


#3

Hello @lindy65

Thank for offering a suggestion.

But I think my problem is a different one. There is no problem with the permissions. The problem is that the PATH to plugins is not found, and as I said, I have a strong feeling that it has got to do in which directory the windows mattermost service is running.
It is running on …/bin and according to a few other threads I read it would be better if the executing directory would be the parent to …/bin

a) I am not entirely sure
b) If I am right, how can I change the service settings? Is there a parameter that could fix it?

Thank you,
Martin


#4

Hi @zwiglm,

Thanks for your feedback,

We have this unofficial Windows installation guide which might have some information regarding the path in your set-up…

Let me know if this helps?


#5

Hello @lindy65

Thank you again for answering. The link you sent is indeed very helpful setting up on IIS and Windows in the first place.
Unfortunately the section of PATH you highlighted has nothing to do with the execution path the windows mattermost service is running in.

As I said - in it is still only an assumption - I think one would have to supply a parameter to the windows mattermost service (or there already is and I haven’t found out)
As I understand is that plugins are in an quite an early stage and it will be figured out in a future version.

Thank you in advance,
Martin


#6

Hi @zwiglm,

Thanks for your feedback :slight_smile:

I’ll ask one of our engineers for help on the PATH issue and post back here with feedback…


#7

I think if you change the start-up directory for the service to c:\mattermost it should work. From here, you should be able to do nssm set mattermost AppDirectory c:\mattermost. If that works, we’ll need to update the documentation to reflect that


#8

Awesome. Going to try it out tomorrow and report back.
Thank you


#9

Yep. Thank you for pointing to this helpful tool and the tip.
Setting the AppDirectory works.


#10

Awesome, glad it works. I’ve submitted a pull request to update the documentation