Mattermost, Inc.

[solved] Password authentication failed for user \"mattermost\""}

For troubleshooting questions, please post in the following format:

Summary

Fresh installation at Ubuntu 18.04.2 LTS 64 Bit
Follow documantation at https://docs.mattermost.com/install/install-ubuntu-1804.html?highlight=database%20installation#installing-ubuntu-server-18-04-lts
Went trough everything. Till starting with sudo -u mattermost ./bin/mattermost

Steps to reproduce

Teamversion V5.13.02 with postgres

Error Output

root@mattermost:/opt/mattermost# sudo -u mattermost ./bin/mattermost
{“level”:“info”,“ts”:1565862870.613147,“caller”:“utils/i18n.go:83”,“msg”:“Loaded system translations for ‘en’ from ‘/opt/mattermost/i18n/en.json’”}
{“level”:“info”,“ts”:1565862870.6134565,“caller”:“app/server_app_adapters.go:58”,“msg”:“Server is initializing…”}
{“level”:“info”,“ts”:1565862870.6159148,“caller”:“sqlstore/supplier.go:224”,“msg”:“Pinging SQL master database”}
{“level”:“error”,“ts”:1565862870.6575272,“caller”:“sqlstore/supplier.go:236”,“msg”:“Failed to ping DB retrying in 10 seconds err=pq: password authentication failed for user “mattermost””}
^C

config.json

"SqlSettings": {
    "DriverName": "postgres",
    "DataSource": "mmuser:secialPassowrdfromme@192.168.1.174:5432/mattermost?charset=utf8mb4,utf8\u0026readTimeout=30s\u0026writeTimeout=30s",

Expected behavior

normal startup.

"SqlSettings": {
    "DriverName": "postgres",
    "DataSource": "postgres://mmuser:SEcurePassword@127.0.0.1:5432/mattermost?sslmode=disable&connect_timeout=10",

The description in the documentation fails (bug). This works for me …
Second error tar -xvfz is not working at standard ubuntu installation. You have tu unzip file in the first step and than tar -xvf without z.

domumentaiton is correct. It was a copy error

1 Like