Mattermost Peer-to-Peer Forum

[solved] Not listening to IPv6 connections


#1

Summary

Apparently MM is only working for IPv4 connections, and not IPv6

Steps to reproduce

Install Omnibus Gitlab on an IPv6 enabled host, enable included GitLab Mattermost

Found out today, while I wasn’t able to use MM at the office I had no issues in using it from home. Then I was testing Webhooks from server and I was getting 404 errors, while from my PC they were working fine. Digging a little bit into the response I found out it was being generated by GL, and not by MM!

While GL is perfectly working on IPv6 it seems that the GL Mattermost enabled hostname is not.
The only doubt I have is that MM has 127.0.0.1:8065 as Listen address. Should it be just :8065?

Installed version: 5.5 (GL 11.6.3)

Thanks


#2

Found it!!

Add in /etc/gitlab/gitlab.rb:

mattermost_nginx['listen_addresses'] = ['*','[::]']

Now MM correctly listens to IPv6!