Mattermost, Inc.

[SOLVED] Mattermost with Jira + Gitlab webhooks

Hi,

I’m having a unusual problem.
I set the webhook for GitLab and it works perfectly. When i activate the Jira integration plugin (Beta), the Gitlab webhook stops working. And the other way works the same way.

I can’t have both working at same time.

Any special configuration is needed?

Version used 4.3 (Last)

Thanks @cpc, interesting.

  1. Which webhook are you using for GitLab?
  2. Do you have other integrations set up on the server? If yes, are they working fine?
  3. Do you see any related errors in the System Console > Logs?

Hi @jasonblais

  1. Incoming Webhook
  2. Yes, Jira using your beta plugion but, as i said, they don’t work together. If i setup Jira last, Jira works but gitlab not, if gitlab last, jira stops working.
  3. No errors

@cpc

  1. Is it a custom webhook integration you’ve built for GitLab?
  2. But no other integrations apart from GitLab and Jira?

@jasonblais

I found my problem and its nothing related to Mattermost.

It seems that gitlab has 2 locations for setting up mattermost integration. One in Admin area and, this one i didn’t know, other in each repository directly.

So since i changed the settings prior to the creation of some repositories, it stopped working because it not applied to the repositories already created.

After corrected, all works fine now.

Thanks for your help. Sometimes we just need someone to hear us “talking” eheh.

Best Regards

Haha no worries. Glad the issue got resolved! :slight_smile: