Mattermost Peer-to-Peer Forum

[solved] Mattermost server doesn't work after instalation.Failed to create index Error 1071

#1

After the instalation mattermost can’t start and shows me this errors:

./mattermost
{“level”:“info”,“ts”:1553426325.7105906,“caller”:“utils/i18n.go:83”,“msg”:“Loaded system translations for ‘en’ from ‘/opt/mattermost/i18n/en.json’”}
{“level”:“info”,“ts”:1553426325.71098,“caller”:“app/server_app_adapters.go:58”,“msg”:“Server is initializing…”}
{“level”:“info”,“ts”:1553426325.7225804,“caller”:“sqlstore/supplier.go:215”,“msg”:“Pinging SQL master database”}
{“level”:“error”,“ts”:1553426325.7914166,“caller”:“sqlstore/supplier.go:807”,“msg”:“Failed to create index Error 1071: Specified key was too long; max key length is 1000 bytes”}

Is there any solution?
Thanx.
CentOS 7.0, MariaDB 10.4, apache. PHPMyAdmin

#2

Hi @francocool,

Which installation guides did you follow? What Mattermost server version did you install?

#3

It was russian guide and i just solved the problem. I used MariaDB for previous installations of mattermost servers, but for new releases this does not work. I used the instructions on the official website and everything turned out. Conclusion - do not use MariaDB for mattermost.