Mattermost Peer-to-Peer Forum

[SOLVED] Mattermost HA problems


#1

Running the Mattermost enterprise version 3.3.0 as of Aug 30th.

I’m running with openstack cloud instances a 3 node galera/mysql cluster, haproxy db lb, 3 mattermost nodes, with glusterfs for file sharing, and a nginx front-end lb. 30 day trial right now.

That setup is working great… for single nodes active. When I change the configs on all the nodes to cluster, each node sits there listening but not hearing. Port 8075 is open bi-directionally.

The log just repeats this continuously:

[2016/08/31 13:43:20 UTC] [INFO] Enterprise Enabled: true
[2016/08/31 13:43:20 UTC] [INFO] Current working directory is /home/ubuntu/mattermost
[2016/08/31 13:43:20 UTC] [INFO] Loaded config file from /home/ubuntu/mattermost/config/config.json
[2016/08/31 13:43:20 UTC] [INFO] Server is initializing...
[2016/08/31 13:43:20 UTC] [INFO] Pinging sql master database
[2016/08/31 13:43:20 UTC] [INFO] Pinging sql replica-0 database
[2016/08/31 13:43:20 UTC] [INFO] Starting Server...
[2016/08/31 13:43:20 UTC] [INFO] Server is listening on :8065
[2016/08/31 13:43:20 UTC] [INFO] RateLimiter is enabled
[2016/08/31 13:43:20 UTC] [INFO] Cluster internode communication is listening on :8075 with hostname=mattermost-1 id=f6sqzgwjrtgoucpsrp6founk8a

Anyone know what’s going on?


#2

There was a problem with our documentation. InnerNodeUrl should be ["http://10.10.10.2", "http://10.10.10.4"] not [“http://10.10.10.2, http://10.10.10.4”]

The documentation has been updated.


#3

That works. Thank you