[SOLVED] Login with SSO and Email/Username with the same account


#1

Hi!

Is it possible to allow users to log in with the same user account using different sign in methods, like using GitLab SSO from one device and using Email/Password from somewhere else?

Thanks…


#2

Hi @dehalion,

I don’t think this is possible as login settings are per server, not per device or browser.

Could you share what your use case is for requiring this?


#3

Hi!

I think my example is unclear, the heading tells already what I want to achieve.

We currently have GitLab SSO for Mattermost. And we have client certificates for GitLab. Both works fine and we like it.

The problem we would like to solve is, that we want to access Mattermost from devices like the mobile or a tablet without installing the client certificates there. These devices don’t need access to GitLab at all and we want to have as little as possible devices with valid client certificates.

We could just switch from SSO to Email/Password for all users, that would work. My question was: can we have the best of both worlds? Log in with SSO if available clicking on the GitLab button, but sign in with the same user account using Email/Password if SSO is not possible on the current device.


#4

Hello @dehalion,

Thanks for the additional feedback,

If you are logging in to the same server from different devices (e.g. computer and phone) it is not possible to log in using different sign in methods.

Sign-in method is set across devices in Account Settings and, as the help text indicates, you may have only one sign-in method at a time.


#5

Ok, that’s what I wanted to know. Only one sign in method per user :frowning:

I didn’t have a message anywhere telling me that (the instance is running in german).
In the Security settings of my account there is only ‘Anmeldung findet über GitLab statt. Das Passwort kann nicht aktualisiert werden.’ (Sign in only with GitLab, password cannot be changed).
And in the system console if I want to change the Sign in method there is only a popup with the password input.

That’s why I asked.

Thank you for your help. I’ll have to look for another solution then…