Mattermost, Inc.

[SOLVED] JIRA Beta Plugin Not Available on 4.5.0

Summary

In a brand new instance of MatterMost using 4.5.0 the JIRA Beta Plugin doesn’t seem to be appearing.

Steps to reproduce

Install 4.5.0 Enterprise Enabled Version

4.5.0 Enterprise Enabled: true

Expected behavior

In the side bar I’d expect to see, under plugins, the JIRA Beta Plugin should be appearing for configuration.

Observed behavior

Don’t see the JIRA Beta Plugin for integration. I do see it in 4.3.1 on my test machine. No JIRA

Hi @KnechtionsCoding,

Thanks for your feedback,

A quick question - have you enable plugins in PLUGINS (BETA) > Configuration > Enable Plugins ?

Here is some documentation that might help:

Let us know if you still experience an issue…

Yes. Here is a screenshot of the plugins page: Plugins Enabled

and to confirm that I went to the config.json where it is also enabled.

Note, I’m more than willing to download and upload the JIRA plugin, but I don’t have a copy accessible for me to upload of the 4.5 version.

@KnechtionsCoding Is there anything plugin-related in your logs? You may have a filesystem permissions issue or something like that.

If you want to try uploading the plugin manually, you can download it here: https://github.com/mattermost/mattermost-plugin-jira/releases/tag/v0.1.2

Here is my logs:

[2018/01/03 08:34:22 EST] [EROR] /api/v4/plugins/webapp:GetActivePluginManifests code=501 rid=ifrb9djiefbcjjbhk3zpnsw7so uid=97mxkppn7tr3pyw7jg1pik8ony ip=172.16.11.196 Plugins have been disabled. [details: ]
[2018/01/03 08:34:35 EST] [EROR] /api/v4/plugins:GetPlugins code=501 rid=x9fmiwi3s38bmr9y7tmi7ua4uw uid=97mxkppn7tr3pyw7jg1pik8ony ip=172.16.11.196 Plugins have been disabled. [details: ]
[2018/01/03 08:34:42 EST] [EROR] /api/v4/plugins/webapp:GetActivePluginManifests code=501 rid=tewu6didepnkfykpf9dmr7h9za uid=uuwht15p8fnpzga66eo6imgaec ip=172.16.11.61 Plugins have been disabled. [details: ]
[2018/01/03 08:34:47 EST] [INFO] Starting up plugins
[2018/01/03 08:34:47 EST] [EROR] failed to start up plugins: mkdir ./client/plugins: no such file or directory
[2018/01/03 08:34:48 EST] [INFO] Starting up plugins
[2018/01/03 08:34:48 EST] [EROR] failed to start up plugins: mkdir ./client/plugins: no such file or directory
[2018/01/03 08:34:52 EST] [EROR] /api/v4/plugins/webapp:GetActivePluginManifests code=501 rid=td8yzm69it8om8bdjaih8dye7y uid=97mxkppn7tr3pyw7jg1pik8ony ip=172.16.11.196 Plugins have been disabled. [details: ]
[2018/01/03 08:34:55 EST] [EROR] /api/v4/plugins:GetPlugins code=501 rid=rqzn76neffnpunow83kgzsy6fy uid=97mxkppn7tr3pyw7jg1pik8ony ip=172.16.11.196 Plugins have been disabled. [details: ]
[2018/01/03 08:35:00 EST] [INFO] Starting up plugins
[2018/01/03 08:35:00 EST] [EROR] failed to start up plugins: mkdir ./client/plugins: no such file or directory
[2018/01/03 08:35:00 EST] [INFO] Starting up plugins
[2018/01/03 08:35:00 EST] [EROR] failed to start up plugins: mkdir ./client/plugins: no such file or directory
[2018/01/03 08:35:06 EST] [EROR] /api/v4/plugins/webapp:GetActivePluginManifests code=501 rid=hn98ghpfypr18yi9n55wcbupka uid=97mxkppn7tr3pyw7jg1pik8ony ip=172.16.11.196 Plugins have been disabled. [details: ]
[2018/01/03 08:35:07 EST] [EROR] /api/v4/plugins:GetPlugins code=501 rid=zkd87nfc7tyt8mjx96s9m1s8ye uid=97mxkppn7tr3pyw7jg1pik8ony ip=172.16.11.196 Plugins have been disabled. [details: ]
[2018/01/03 08:37:45 EST] [EROR] /api/v4/plugins:GetPlugins code=501 rid=behk9g6fr7gjufedphacc6765e uid=97mxkppn7tr3pyw7jg1pik8ony ip=172.16.11.196 Plugins have been disabled. [details: ]
[2018/01/03 08:37:49 EST] [EROR] /api/v4/plugins:GetPlugins code=501 rid=7j55yb6x33yg3fdjws38og88gh uid=97mxkppn7tr3pyw7jg1pik8ony ip=172.16.11.196 Plugins have been disabled. [details: ]
[2018/01/03 08:37:59 EST] [EROR] /api/v4/plugins:installPlugin code=501 rid=gwnjacdtfp8cuq9hqk4o9majjr uid=97mxkppn7tr3pyw7jg1pik8ony ip=172.16.11.196 Plugins have been disabled. [details: ]

However when I check the file system permission they appear to be intact:

Filesystem permissions

I tried uploading the plugin manually and it told me plugins were disabled?

@KnechtionsCoding Can you share the service configuration you’re using?

For example on Ubuntu 14.04 it might be:

start on runlevel [2345]
stop on runlevel [016]
respawn
limit nofile 50000 50000
chdir /opt/mattermost
setuid mattermost
exec bin/platform

Running on CentOS, here is the service configuration:

mattermost

Do I need to move it up a directory to the /opt/mattermost/ directory so it finds client?

Try setting your WorkingDirectory to /opt/mattermost, that should fix it

Okay. I took the documentation from here: under the service part:

https://docs.mattermost.com/install/install-rhel-71.html

So that should probably be updated.

That now resolved it. Not sure if I can submit a PR to update that documentation anywhere.

@KnechtionsCoding If you click the “Edit” button on the top right corner of the page, you can edit the page and submit a change for us to review.

That would be very much appreciated!

image

Done. This issue can now be closed.

1 Like

Thanks @KnechtionsCoding, pleased your issue is resolved!