Mattermost, Inc.

[SOLVED] Import cycle not allowed after merge

I recently just merged my modified version of MM 3.6.0 with the 3.7.5-rc1 branch (with http fix on a further branch) and although there were a couple of conflicts, all were resolved easily.

However, when I do make run or make build I get the following error:

import cycle not allowed
package main
	imports github.com/mattermost/platform/api
	imports github.com/mattermost/platform/app
	imports github.com/mattermost/platform/app

Unfortunately, Go is not a strong suit of mine (nor is React for that matter) so any help would be appreciated. Obviously before the merge everything was running fine on these commands. Incidentally the error is slightly different between the commands. If I build rather than run, instead of package main, I get package github.com/mattermost/platform/cmd/platform I’ve done a search through the entire app and cmd/platform is not imported in app or api, so not sure how this import cycle is occurring.

Thanks in advance,

Mike

EDIT: Also wanted to add that I’ve done a couple of make cleans too.

Hi @MikeDaniel18 is there a reason you are merging with 3.7.5-RC1? We have released 3.8.2 and I would recommend upgrading due to a number of security fixes. Please let us know if you hit any issues with the upgrade.

I’ll be honest, there isn’t really a reason. It was one of the first ones I saw. I’ll give the merge with 3.8.2 a go and respond if I have any issues. Thank you :slight_smile:

Thanks @MikeDaniel18,

I’ll mark this issue solved for now but let us know if you have any further questions!