Mattermost, Inc.

[SOLVED] Gitlab Omnibus 9.3.x installer does not upgrade Mattermost

Summary

Gitlab Omnibus installer did not upgrade Mattermost.

Steps to reproduce

On Amazon Linux 2017.03

Previously:

  • Gitlab and Mattermost are both working.
  • gitlab version was 9.3.x.

These command were executed:

Expected behavior

Observed behavior

  • Mattermost app in brower show the version, but the version is still 3.10.0.

  • The log file, /var/log/gitlab/mattermost/current has the line:
    Current version is 4.0.0 (4.0.1/Wed Jul 19 00:54:25 UTC 2017/a350f4dc0754e1aeabb64bd712ce05f7c59cfa60/none)

  • The img src of user icons on the app points URI out like this:
    /mattermost.mypage.net/api/v4/users/xztgtqdkjprhzqcskm5dojxdth/image?time=1501070387379

  • Directly accessing to the URI, it returns:
    {“id”:“api.context.session_expired.app_error”,“message”:“Invalid or expired session, please login again.”,“detailed_error”:"",“request_id”:“5wm9ctiyxbdu5q689ea8b7cpgo”,“status_code”:500}

This problem is fixed.

On previous update, mattermost is restarted in the following way:

My mistake was that the mattermost process that kicked by the command described in the article above cannot be killed by the gitlab update procedure. After killing the process, mattermost version 4.0 process can be started.

Thanks,