Mattermost, Inc.

[Solved] Error starting last mattermost version from master `[Error: write after end]`

Hello,

When I try the last mattermost version from master I have the following error

Error: EMFILE, open ‘/home/jylebleu/devmisc/go/src/github.com/mattermost/platform/web/react/package.json’
[Error: write after end]

Was not the case with version 1.0.0

git checkout v1.0.0
make clean
make run

Is ok

I have the same error with tag v1.1.0 and later

Any clue ?

From https://github.com/mattermost/platform/blob/master/doc/developer/Setup.md

Set up your Go workspace
mkdir ~/go
Add the following to your ~/.bash_profile
export GOPATH=$HOME/go
export PATH=$PATH:$GOPATH/bin
ulimit -n 8096
If you don't increase the file handle limit you may see some weird build issues with browserify or npm.

I think you need the ulimit increased.

Thank you very much you got it !

Shame on me I was on the way to reread carefully the doc.
Everything works well
Good job