Mattermost, Inc.

[SOLVED] E-Mail notifications not send

Summary

Invitation links and notifications won´t be send via E-Mail

Steps to reproduce

Mattermost Version: 4.10.1
Database Schema Version: 4.10.0
Database: postgres

EmailSettings in config.json:
“EmailSettings”: {
“EnableSignUpWithEmail”: true,
“EnableSignInWithEmail”: true,
“EnableSignInWithUsername”: true,
“SendEmailNotifications”: true,
“UseChannelInEmailNotifications”: false,
“RequireEmailVerification”: false,
“FeedbackName”: “Gitlab”,
“FeedbackEmail”: "service@git.hot-sushi.com",
“FeedbackOrganization”: “”,
“EnableSMTPAuth”: true,
“SMTPUsername”: “###smtp-username###”,
“SMTPPassword”: “###smtp-password###”,
“SMTPServer”: “###smtp-server###”,
“SMTPPort”: “587”,
“ConnectionSecurity”: “TLS”,
“InviteSalt”: “###invite-salt###”,
“SendPushNotifications”: true,
“PushNotificationServer”: “”,
“PushNotificationContents”: “generic”,
“EnableEmailBatching”: false,
“EmailBatchingBufferSize”: 256,
“EmailBatchingInterval”: 30,
“SkipServerCertificateVerification”: false,
“EmailNotificationContentsType”: “full”,
“LoginButtonColor”: “”,
“LoginButtonBorderColor”: “”,
“LoginButtonTextColor”: “”
},

Expected behavior

As we would like to send E-Mails for invitation, we configured mattermost to use an external smtp server. After adding a recipient and filling in the name for the “send invitation” form, the form is send with the response “ok”, but we are not recieving any mails. I´ve replaced critical data within the provided settings array with ###somewhat###, just for clarification.

Observed behavior

The form for e.g. team invitation is submitted and gets the following response:
{“status”:“OK”}

Neither the external mail service nor our own smtp server at hot-sushi.com receives any mails to be send.

I would be pleased if you could take a look, thanks in advance!

With best regards,
Patrick Nußbaum

Hi @patricken! Thank you for reaching out.

As a first step, can you help take a look at this doc if any tips help: https://docs.mattermost.com/install/smtp-email-setup.html

Hey Amy,

im a bit ashamed, it was the encryption which had to be starttls. Thanks for the link, I should read the docs properly!

@patricken No worries at all! Glad to hear the issue is resolved.