Mattermost, Inc.

[Solved] Debian Jessie Installation Howto - Error on Step 8

Hello,

at Step 8 of the Debian Howto ( http://docs.mattermost.com/install/prod-debian.html ), i´m getting the following Error:

root@mattermost:~# systemctl daemon-reload
root@mattermost:~# systemctl enable mattermost
Synchronizing state for mattermost.service with sysvinit using update-rc.d…
Executing /usr/sbin/update-rc.d mattermost defaults
insserv: warning: script ‘K01mattermost’ missing LSB tags and overrides
insserv: warning: script ‘mattermost’ missing LSB tags and overrides
Executing /usr/sbin/update-rc.d mattermost enable
update-rc.d: error: mattermost Default-Start contains no runlevels, aborting.
root@mattermost:~# systemctl start mattermost
Failed to start mattermost.service: Unit mattermost.service is masked.

Thanks in advance!

edit:
I have now installed nginx and after a manuel mattermost start (/opt/mattermost/bin/ ./platform), the website is working.
The Problem above still exists so any help is welcome!

Sorry for my bad english!

Hi Knorkator,

Can you try removing the file from /etc/init.d/mattermost and copy it to /etc/systemd/system/mattermost instead?

Let me know if that works for you so I can update the instructions.

Christopher

Hi Christopher,

That is the solution.
I have this figured out already by the Debianforum.de
https://debianforum.de/forum/viewtopic.php?f=12&t=161271

Thank you for your contribution