Mattermost, Inc.

[SOLVED] Blank page - Several browsers and platforms

Hi everyone,

I’ve just finished installing MM 3.0.2 and in several cases (my coworkers and Chrome in my Android phone) display the login URL but with a blank page. My installation URL is: https://mm.initech.pw/

So far this is what I’ve found:
Ubuntu 14.04 - Chrome - Version 50.0.2661.102 (64-bit) --> WORKS
Ubuntu 14.04 - Firefox 46.0 --> WORKS
Android - Chrome 50.0.2661.89 --> BLANK PAGE
Ubuntu 14.04 - Chrome - 50.0.2661.86 (64-bit) --> BLANK PAGE
Ubuntu 14.04 - Firefox - 46.0.1 --> BLANK PAGE
Ubuntu 16.04 - Firefox 46.0.1 --> BLANK PAGE
Ubuntu 16.04 - Chrome 48.0.2564.116 (Build oficial) (64 bits) --> BLANK PAGE
Ubuntu 16.04 - Chrome - Version 50.0.2661.102 (64-bit) --> BLANK PAGE

As you can see, the first and the last results are using the same browser release!

Log file doesn’t show anything abnormal that I should care about:

[2016/05/23 11:46:59 ART] [INFO] Enterprise Enabled: false
[2016/05/23 11:46:59 ART] [INFO] Current working directory is /opt/mattermost
[2016/05/23 11:46:59 ART] [INFO] Loaded config file from /opt/mattermost/config/config.json
[2016/05/23 11:46:59 ART] [INFO] Server is initializing...
[2016/05/23 11:46:59 ART] [INFO] Pinging sql master database
[2016/05/23 11:46:59 ART] [INFO] Pinging sql replica-0 database
[2016/05/23 11:46:59 ART] [INFO] Starting Server...
[2016/05/23 11:46:59 ART] [INFO] Server is listening on :8065
[2016/05/23 11:46:59 ART] [INFO] RateLimiter is enabled
[2016/05/23 11:47:05 ART] [INFO] Stopping Server...
[2016/05/23 11:47:12 ART] [INFO] Current version is 3.0.0 (3.0.2/Tue May 17 21:26:28 UTC 2016/ac509b114df1c1b4b841eded74fb797805e0162d)
[2016/05/23 11:47:12 ART] [INFO] Enterprise Enabled: false
[2016/05/23 11:47:12 ART] [INFO] Current working directory is /opt/mattermost
[2016/05/23 11:47:12 ART] [INFO] Loaded config file from /opt/mattermost/config/config.json
[2016/05/23 11:47:12 ART] [INFO] Server is initializing...
[2016/05/23 11:47:12 ART] [INFO] Pinging sql master database
[2016/05/23 11:47:12 ART] [INFO] Pinging sql replica-0 database
[2016/05/23 11:47:12 ART] [INFO] Starting Server...
[2016/05/23 11:47:12 ART] [INFO] Server is listening on :8065
[2016/05/23 11:47:12 ART] [INFO] RateLimiter is enabled

Would you help me find out what’s wrong with that?

Thanks in advance!

Hi leonardo,

can you please tell me what are the default language for those browsers where the blank page is ocurring?

Thanks

Hi Elias, you are awesome! :+1:

My colleagues with the problem, they only have Spanish and Portuguese… I also have English, that’s why I can see it without problem.

I can’t find in docs.mattermost.com how to install additional languages into our server. Would you mind telling me where are those instructions located?

Many thanks!

Hi Leonardo,

Actually the languages are already available in Mattermost, but it seems that 3.0.2 had a little problem when loading different languages.

Can you be so kind and try this build on linux to see if that fixes the problem for you?

Much appreciate it.

Thanks

@leonardobertolo Mattermost 3.0.3 is available now and should include a bug fix for this. Please let us know if it solves your issue?

Hi @elias and @it33, thank you very much for your quick reply, sorry for my delay in answering.

I did a clean install of version 3.0.3 and it worked perfectly. Now I can see it in Spanish, English and Portuguese!

Thanks again for your help!

Best regards

Perfect, thanks @leonardobertolo! Appreciate your report, very helpful!