Mattermost, Inc.

[SOLVED] Access-Control-Allow-Credentials' header is ''

Summary

I got Access-Control-Allow-Credentials’ header is ‘’ in response after trying to connect with mattermost server along with its Rest api

Steps to reproduce

Expected behavior

  • After entering the right credentials, I excepted to receive session token but got this error:
    Response to preflight request doesn’t pass access control check: Credentials flag is ‘true’, but the ‘Access-Control-Allow-Credentials’ header is ‘’. It must be ‘true’ to allow credentials

Thanks for the report @nirina,

I’ll close this issue off here and we can track via the GitHub issue that you opened :slight_smile: