Mattermost, Inc.

SessionIdleTimeoutInMinutes doesn't look like working. (v4.3.4)

Summary

SessionIdleTimeoutInMinutes doesn’t look like working (Mattermost v4.3.4)

Steps to reproduce

I set “SessionIdleTimeoutInMinutes”: 60 (changed it from default zero) and restart MM v4.3.4 server,
but the session on the firefox browser remained connected even after pasting 60min.

Any tips to make it effective?

Observed behavior

The MM server was running v4.2.0 for two months on AWS EC2 AML, then updated to v4.3.4 yesterday.
The config.json was not copied from the previous one, but put our local customization on the distributed original one.
I’m wondering the setting might conflict with the other Session related settings like:

grep Session /opt/mattermost/config/config.json

    "SessionLengthWebInDays": 30,
    "SessionLengthMobileInDays": 30,
    "SessionLengthSSOInDays": 30,
    "SessionCacheInMinutes": 10,
    "SessionIdleTimeoutInMinutes": 60,

Thanks for your helps,

Hi, looking through the v4.3 Changelog, it looks like the function is effective only on Enterprise Edition, while my installation is the Team Edition. It would be better to look for true OSS. thx.

@Satoshi.Suzuki, you are correct. These settings are only used by Mattermost’s Enterprise Edition, as they are related to compliance/security, two of the areas that our enterprise customers are most interested in.