Mattermost Peer-to-Peer Forum

Server online need help with configuration


#1

Summary

So everything on Mattermost is running correctly. However I am unsure how to do a few things.

  1. Set up an email server on Ubuntu and connect it to MM.

  2. Send out notifications to the mobile app.

  3. Setup https

  4. Change default colors

  5. Get screen shot of the site when linked from Facebook. (currently shows 404 error)

Any help would be great. Would be willing to pay for support as well.

Site is @: http://www.yspac.org

Steps to reproduce

I am using Mattermost 5.4 on Ubuntu 16.04.

Expected behavior

Working configuration.

Observed behavior

Running server minus above features.


#2

Hi @coreywhite,

Here are links to docs that should help:

  1. Email: https://docs.mattermost.com/install/smtp-email-setup.html

  2. Push notifications: https://docs.mattermost.com/help/getting-started/configuring-notifications.html#mobile-push-notifications and https://docs.mattermost.com/administration/config-settings.html#mobile-push

  3. Https: https://docs.mattermost.com/install/config-tls-mattermost.html

  4. Colours: https://docs.mattermost.com/help/settings/theme-colors.html

  5. Facebook: Can you help with more details on what you want to achieve here?

Let me know any questions.


#3

Ok so lets start with colors & themes.

/opt/mattermost/config/config.json

^ the above config file has a place for themes:

"ThemeSettings": {
    "EnableThemeSelection": true,
    "DefaultTheme": "mattermostDark",
    "AllowCustomThemes": true,
    "AllowedThemes": []

As you can see I changed my Default Theme & it still uses the original default.


#4

Hey, are you using Mattermost Enterprise Edition E10 or higher?

Otherwise (if your’re using Team Edition), changing these settings in your config.json will make no difference. Was confusing for me, too, at first. But config.json contains ALL possible settings (for Team Edition and Enterprise Editions) and a system check at server start will make sure, if your config changes are “allowed” with your license or not (for reference regarding themes see here: https://docs.mattermost.com/administration/config-settings.html#theme-settings-experimental).

In case you ARE using an Enterprise license, I’d try a mattermost server restart. Make sure the logs (in DEBUG mode) will show a line like this:
date-time-etc info commands/server.go:83 Enterprise Enabled: true


#5

Ok, I’m using the free edition so that explains it.

Next question, I’m following your guide but can’t setup https. It wants the root www directory for mattermost,


#6

Hi @coreywhite,

Can you help with more details on your config settings as well as any error messages that you’re seeing?


#7

Could you tell me where to find the config settings?


#8

Hi @coreywhite, the settings from System Console > General > Configuration will be helpful if you chose to set up TLS on Mattermost Server, or let me know if you chose another option.


#9

Thanks for your help. I was able to fix my problems by installing Ubuntu 18. I was running 16.04 and the setup was way smoother on 18. :slight_smile: